Beachball after update?

Ah drat it. I was hoping the powering down would work on your Mac like it did on mine.

Since this is a brand-new issue being reported since this new macOS update, I’m trying to gather as many facts about the computers and projects affected to see if that will help the developers with diagnosing this.

If you go to Scrivener > Settings > General > Saving, what is the autosave interval currently set to? The default is two seconds of inactivity.

If you bump that up to 10 seconds, does the beach ball issue improve?

Also, about how many MB or GB is the project(s) that are lagging? And, is it/are they stored on your Mac’s hard drive? Or, are they stored in a cloud-syncing service? If you’re storing the project(s) to a cloud server, which are you using?

The more data we can collect on this, the better.