Beta 12: Styles don't survive a CR

I use my own style for most text, defined as Body Text. If I set it at the beginning of a new text file, when I hit [Enter], the new paragraph is unstyled.

Did you choose “This Style” in the Next Style line at the bottom of the dialog box at “Format → Style → New style from selection”?

I’m betting that’s the issue.

To fix it, Format → Style ->“Redefine style from selection” → Body Text → Next style.
Click This Style (if it’s present) or Body Text, if it’s in the list.

I’ve been frustrated by this issue as well and am pretty sure it’s an actual bug.

I have created a custom text style called “LPF Text” which I use in this image:

As soon as I hit return, the cursor drops to the next line as expected but the style is lost (reverts to “No Style”):

Note that we do not recommend doing this. Most of the text in your manuscript should be unstyled. More information about Scrivener’s approach to styles can be found here: … th-style-s


Doesn’t happen here. Here’s why:

That menu at the end of the Dialog box when you REDEFINE or CREATE a style – it defines what style is NEXT.

FYI: “Format → Style → New Style from Selection” OR “Format → Style → Redefine Style from Selection.”

If that box looks like this:

Then Scrivener will do EXACTLY what you say it’s doing, because the next style is set to “none” which is, of course, no style at all.

To CHANGE it, select a paragraph in your style. Format → Style → Redefine style from selection.
At the BOTTOM of the Dialog box, click in the dropdown menu of styles, and select the style you want as the next style. Click OK.

What you want should now happen.

However, it would be better (as noted by another) if you set “No Style” to your expected default, unless you have some over-riding reason not to (and there are some, I know).

Thank you both. I wasn’t previously aware of the need to set the Next Style dropdown to maintain the current style after a carriage return / enter. That’s exactly what I needed and now it works as I expect! :slight_smile:

I understand the general idea from the article Katherine shared on why we may usually want to use No Style as our default text style but I prefer to follow a named style for all text (and have created a custom template with all styles I used defined for the type of project I work on for this - a monthly newsletter).

With this help I agree this is not a bug but rather a user education issue. :bulb: I’m more educated now - thank you again! :smiley:

One thing to keep in mind is that it could be easy to miss some text with your baseline style and not know it. You may have to add that style to a custom compile preset, and apply that style to all Section layout “Text” in the example Formatting window. This will ensure that all unstyled text is styled at compile time.

Your work is your work, but please be aware that your preference conflicts with how Scrivener is designed. You are quite likely to encounter additional unexpected behavior as you start to Compile your work out of Scrivener.


Scrivener is flexible enough to do things that way, but the designers think it’s not a good idea (as mentioned by Kewms and myself).

Given your preference, you might want to set the default style, the “No Style” style (Options → Editing → Formatting) to some font that you would NEVER use for your projects. Maybe Wingdings or some such, in a large (72-point?) bright blue boldfaced font. That will tell you immediately to use a different style, if for some reason you’re in “No style” when you don’t want to be.

I know I don’t watch the style dropdown all the time.