Beta 27 Crash on Open Project

I am running Windows 10 (64 bit) and I’m using Scrivener 1.9.9 successfully.

I thought it would be a good time to check out the beta. I downloaded the install and ran it. I changed the install folder to c:\program files\Scrivener3 to preserve my existing installation.

When I try to open the Interactive Tutorial, it asks me for a name, no problem, I expected that. After moving to my writing folder and providing a file name, Scrivener unceremoniously crashes. I tried rebooting. I also tried while watching Task Manager. Sure enough, the process just disappears.

I then tried to just create a blank project. Same thing.

Scrivener 1.9.9 continues to run successfully.

Any advice?


Additional info. When I look out on the disk it appears the project files are not completely written.

For example, this is what I get when I double click on the .scrivx file for the blank test project that I just attempted to create:

Is it possible that Scrivener is failing to write these files as it is attempting to create the project?


Hmm. No response. Have I posted in the wrong forum?

You are in the right forum. :mrgreen:


Hmmm. Do I have an unrealistic expectation that I will get a response on a bug report? Especially regarding a crash?


Hi Tom,

As I’m sure you’re aware, the devs are a tad busy. Sometimes they respond super quick, sometimes not so much. Extending grace is called for in this scenario. :slight_smile:

I follow these forums closely, and (I think) your report is the first I’ve seen of this issue, so my guess is that it is something very specific to your environment. What’s your antivirus situation? Just using Win Defender? Or something else?

As Beta 28 was just released, you might want to try uninstalling B27 and installing B28. Do install to a separate program folder, as you did with 27.

If you still have the same problem creating/opening the Tutorial with B28, you might also want to try creating a new blank project with the beta, just as additional input for the devs, when they eventually they follow-up on this issue.


Thank you, JImRac.

I am running Win Defender, it’s a fresh install of Win 10 (64 bit). Though I doubt an antivirus would interfere intermittently with the creation of files on my disk.

As noted above, I did try creating a fresh project with Beta 27. Several times actually. With appropriate variations of reboot, uninstall/reinstall, etc. Seems very systematic.

I will attempt a new installation of Beta 28.

Thanks again,

Please, also make sure that Scrivener v3 Beta is installed in a separate folder from the Scrivener v1 installation.

Yep. Did that too. Will also do that with Beta 28.


Hi Tom,

Are you still experiencing this problem with Beta 28? Or were you able to successfully create a project with this version?

I’ve hesitated to chime in until now, as I’m having the same issue. Scrivener crashes on project open.

In the Windows event logs I see an event ID 1000 Application error when Scrivener.exe crashes (both b27 & b28)

Faulting application name: Scrivener.exe, version:, time stamp: 0x5dc28ff0 Faulting module name: msvcrt.dll, version: 7.0.17763.475, time stamp: 0xf362c2f9 Exception code: 0xc000041d Fault offset: 0x0000000000074b60 Faulting process id: 0x24bc Faulting application start time: 0x01d59a3ae64055f1 Faulting application path: C:\Program Files\Scrivener\Scrivener.exe Faulting module path: C:\Windows\System32\msvcrt.dll Report Id: 74265d9b-f703-4461-98f5-409045a40bb6 Faulting package full name: Faulting package-relative application ID:

Followed by an Event 1001 from Windows Error Reporting

[code]Fault bucket 1930492254769726454, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: Scrivener.exe
P3: 5dc28ff0
P4: msvcrt.dll
P5: 7.0.17763.475
P6: f362c2f9
P7: c000041d
P8: 0000000000074b60

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: 74265d9b-f703-4461-98f5-409045a40bb6
Report Status: 268435456
Hashed bucket: 1226a61e6e3539e94aca7c7a3f3143f6
Cab Guid: 0[/code]

However, at this point I’m stumped. Are there some other Scrivener specific logs I can dive into?

The projects open just fine on my Mac v3.1.14 of Scrivener.

Just to clarify, is this happening both when attempting to open existing Projects and when trying to create new ones? Or just one or the other?

I tried opening an existing project - in fact I have it re-open the previously open project by default. Crashes. I removed the project, forcing it to the welcome dialog, where I tried to create a new blank project. It partially created the project, based on one folder and two files on disk, and then crashed. Also, when going to the welcome dialog, I can choose an older project, it will ask to backup/upgrade, I say yes, it creates the backup, then crashes on opening the processed project.

The crash is caused by the following dll file in your Windows system 32 folder:
Some third party application or you have placed this file in this folder and I believe this is causing a problem. Try renaming this file if possible at all and run Scrivener again.

The Microsoft Visual C+ RunTime (msvcrt.dll) is a component of the Windows OS.

Just to make sure that wasn’t the culprit, I pulled down the latest version from Microsoft and installed it. No change.

So I guess back to a core question - where does the Scrivener log live, and how do we increase the logging level to get as much detail as possible?

I’ve been able to get the interactive tutorial to open, however all pre-existing projects cause it to crash. These projects still open on the Mac w/o issue - however occasionally the Mac thinks the file is still open - I expect due to a file created during the attempted project open? Exactly how much seems to get created (files/folders) seems to vary some, but I’m guessing that is due to how long it takes Scrivener to actually complete application crash.

I’ve also noticed that it is touching something within pre-existing projects when it attempts to open them, as the modified date on the folder changes to “now”.

The Scrivener log seems like it would be a big help.

Well, I’ve resolved this, though I still don’t have specifics on how. I re-applied the latest updates, re-applied the latest Visual C++ runtimes, re-installed the latest beta of Scrivener and it started working again.

My apologies for not having a concrete solution, or cause… but in case it decides to start crashing on you, best I have is to re-apply latest OS updates and reinstall latest version of Scrivener.