"Binder" deleted itself

See image…

This is how it happened (I think):
I partially write on an iPad in the “Notebooks” app and sync it with Scrivener every few days. After syncing this morning, The content of the Binder was there, but “Binder” itself had disappeared…
I quit Scrivener and started it up again, to no avail.

Best, R.
Bild 3.jpg

That’s… weird. And should never happen. Could you please try creating a new project and see if you can get it to happen again following the same steps? I’m at a loss on this one. The binder tab is technically the same as other collection tabs but it disables the user from editing the title. The title can still be changed in code, though, so Scrivener must have done something accidental behind the scenes. I’m not sure what, though, seeing as syncing with Folder Sync should never affect the binder collection. So anything you can do to help reproduce this would be much appreciated!


Sorry. Can’t reproduce this. I deleted the project and copied it’s contents into a new project. No problems there.


Strange. It must be something during the sync process that calls on the collection to rename itself, but I have so far been unable to track down the cause in the code. It’s bound to be something simple - a single line of code that needs an extra conditional statement - so I’ll go through it again, but if you do find a way of reproducing it, let me know as that would make it easier to find.

I went to open the project from last years NaNoWriMo, and the Binder is gone. I could restore from a backup, but I would lose 2/3’s of my ‘novel’ and that is unacceptable. I would hate to think this would happen again.

I use 2.0, sync everything via Dropbox and hadn’t touched the project for at least a month or more. This is every puzzling to me.

When you say “the Binder is gone,” do you mean that the contents of the binder are missing or that the binder itself isn’t showing up in your Scrivener window? Are all the contents gone, or are the Draft, Research, and Trash still there? Also, the project was originally created in 2.0 and not a 1.54 project that you upgraded?

I got a screen that told me that the ‘binder.scrivproj’ file was gone. Everything else was there (I presume), but that was gone. Now, after poking around my system for a while, I found a backup that allowed me to retrieve everything without the hassle of importing everything into a new project…but, I was a bit unnerved that the ‘binder’ file was gone or corrupt or whatever. (I immediately made a backup of this…)

I’d started the project under 1.54, then installed 2.0 around 11/12. I went through the end of November with ary a problem. It seems I opened it up around 12/19 as that was the last backup. So, all this time and for some reason the ‘binder’ file was toast.

What happened?

Keith or Ioa will be able to give you a better answer, I’m sure, but to me it sounds like the project didn’t upgrade properly. The binder.scrivproj is an old file from 1.54; it doesn’t exist in 2.0. So it really shouldn’t have been there at all once you updated the project, I think, but in the earlier days of 2.0 there were a few glitches with the process for some projects. I know I had one that worked fine but when I went looking into the package later, it had a few leftovers from 1.54 that hadn’t been cleaned up in the conversion. So you might have had something like that, and then gotten the message at some point when either files got changed (by Scrivener or by Dropbox, as that occasionally happens in a network hiccup) or Scrivener otherwise got confused by the 1.54 files in the project package. Since you had everything working in 2.0, I don’t think that the binder.scrivproj file being missing at that point should really have mattered (presumably Scrivener wasn’t actually using it for anything), but I’m completely hypothesizing here, so don’t listen to me too closely. :wink:

At any rate, I’m glad you have your project working!

Well, it was a bit disconcerting to not have the project open when I wanted it to and I had to go 'round Robin Hood’s barn to get it to do so.

Come to think of it, I hadn’t opened the project between the 1st and 2nd update to 2.0 so I wonder if that had anything to do with it?

Oh well, it’s working now and that’s what is important. All in a lifetime, right? :slight_smile:


I doubt this was caused by the update process - the message about the .scrivproj file being missing means the update process hasn’t found one of the necessary files; it won’t have caused it. A .scriv project is really just a folder of files, and in 1.x the binder structure was stored in a file entitled binder.scrivproj (in 2.0 this has a new XML format and its extension is now .scrivx). Did you copy the project between volumes at all, or store it somewhere and then move it? The most obvious explanation I can think of is a copying error whereby when transferring it between volumes not all of the internal files got copied.

Thanks and all the best,

See, I told you not to listen to me! 8)

So fascinatingly enough, I got this to happen to a whole folder of Scrivener projects, presumably via a Dropbox error. In my case, the version.txt file got wiped from the projects, so when I tried to load them I got the aforementioned error message about the project appearing to be an older version but with no binder.scrivproj file. (The projects in question were created in 2.0.) Copying the text file from another project and pasting it into the “Files” folder of the corrupted project fixed it.

They’re also all missing the Project Notes folder, although I’m sure none of them had project notes, so I don’t know if that got wiped because Dropbox turned up its nose at the boring empty .xml file inside or what. The folder just gets recreated when you make notes, but I suppose if this is a common Dropbox issue, your notes might’ve gotten lost then and obviously copying the version.txt file won’t fix that. I don’t use Dropbox for syncing unzipped projects, but I assume it doesn’t always wipe the files or other people wouldn’t regularly do it. :slight_smile: I definitely had the sync interrupted while uploading these projects and other files.

Anyway, just wanted to share in case that’s helpful for anyone. Also because I’m procrastinating. Whee.