Binder drag-and-drop quirk

I have either found a bug, or a spiffy feature I don’t know how to use yet. :wink:

I have my project binder set for spring-loaded folders.

My Draft folder contains this:

I just encountered a quirk where if I select e.g. 4 contiguous documents in Folder 3, and drag them into Folder C, once C gets out of spring-loaded mode, the 4 documents that occupy the space I dragged FROM are selected in the Binder. E.g., if I dragged-and-dropped Documents A through D into Folder C, then I would end up with Folder C closed, and Documents E through H selected.

If I drag ONE document, Scrivener behaves normally and I end up with no documents selected in the binder.

If I drag multiple documents from further down the list, not including Document A, Scrivener again behaves normally.

If I drag to any folder other than the folder immediately above the documents, Scrivener behaves normally.

If the target folder is at a different level of hierarchy than the source documents, Scrivener behaves normally.

AFAICT the quirky behavior ONLY happens if ALL of these are true:

  1. my selection includes the 1st document below a folder – in this case, Document A, which is below Folder C.
  2. I select multiple documents;
  3. the documents are contiguous in the list (if I drag-and-drop A, B, and C, I get the problem; if I drag-and-drop A, B, and D, Scrivener behaves normally);
  4. the documents contain no nested documents;
  5. I drag the documents into the folder immediately above them in the list, which is at the same level of hierarchy as the documents

The folder I am dragging to does not need to be at the top of the Binder list of items in that folder. The items above it in the list can include both folders and documents.

The documents I am dragging do need to be listed immediately below the target folder.

I was able to reproduce the problem behavior in a second project. It occurs whether the folder containing the target folder and documents (Folder 3 in my example above) is in the Draft folder, the Research folder, or at the top level of the Binder.

HTH bug-stomping!

All the best,
Joy

I should also note that when items in the Binder get highlighted by this quirk, it does not shift the focus of either Editor window.

Hi,

Sorry, I can’t reproduce this. Could you please provide simple numbered steps that I can take to see it for myself? I tried following the ones you provided but I didn’t see the odd behaviour, so I must be missing something.

Thanks!

All the best,
Keith

Here are the steps:

  1. Create a folder, and inside it place or create 1 or more folders. Below the folders, at the same level of hierarchy, create or place a series of documents. (It does not matter whether the folders contain other items, or whether the documents contain content.) Screen shot:

drag-bug-1.png

  1. Close the bottom (target) folder, and make sure spring-loaded folders is turned on. Now select a CONTIGUOUS set of files immediately below the target folder. Screen shot:

drag-bug-3.png

  1. Drag the files you selected into your target folder immediately above them. The same number of files you selected will now be selected immediately below your target folder. Screen shot:

drag-bug-4.png

BTW I found in replicating this that in order to get the bug, I did NOT get the behavior if I selected the folders, took a screen shot (Command-Shift-4), and THEN dragged. I DID get the behavior if I selected and then dragged immediately afterward. However, I CAN select, switch applications, do something in the other app, return to Scrivener, drag, and get the behavior.

HTH!

All the best – and happy bug-stomping,

Joy

Okay, I’ve got it - it only happens if you drop on the folder so quickly that it doesn’t get time to auto-expand. I’ve fixed it for the next update, thanks!

All the best,
Keith