Binder selection colour changing

Hey,
I have been experimenting with arranging the binder to work with my work flow and now have a black background with my chapters highlighted using label background colours. Since I have a black background the type is now white - which looks pretty cool and is easy to navigate.
My issue is two fold:

  1. When I select a chapter slug line the background colour turns blue - can this colour be changed?
  2. When I select a chapter to call up that chapter on my main page then click to begin writing, the binder slug line background turns white and the white text is unreadable. - Is this fixable?

Thanks
Richard

The selection color is set by your System Preferences. You can change this by going to System Preferences → General.

I don’t see a way to change the active binder item color, but there very well may we a preference I’m overlooking. I would be curious to see if someone has an answer for that as well.

The binder selection colour is typically straightforward, in that if you have Base selection color on background color enabled in the Appearance: Binder: Options preference tab, then it will be use a tint based on the selection made in the Color tab. If you turn that off, then it uses the system highlight colour.

That’s actually the default setting, but because in macOS 11 the binder colour default is now white instead of blue—white, along with black (and very near choices) trigger a secondary behaviour of falling back to the system highlight colour since there isn’t much to tint the selection with.

So, if you want to control the colour a bit, you would need to settle for something not black, but you can get close to it (try around 7% brightness). From there you can control the colour with the saturation and hue sliders in the second colour tab.

One down one to go thanks.
I solved the blue highlight by going to the iMac prefs - whoda thunk this would be controlled by Mac - and changing the Highlight colour to a custom grey.

However, I still can’t figure this out…
When I select the Scene I want to go to in my Binder (now highlighted grey not blue) and that scene appears in my Editor, when I click the Editor the Binder scene slug highlight still changes from grey to light grey. Making my white text (wht because of my blk. bg) disappear.

Sorry difficult to explain without a screen grab.

AmberV’s instructions should work for that.

Go to Scrivener → Preferences → Appearance → Binder → Options. Uncheck “Base selection color on background color.” On my machine, doing this with the binder set to black causes the active binder document to default to a darker grey.


Here is the issue.
Originally the top example highlight was blue and I changed it to grey.
The bottom example shows what happens when I click on the scene in my edit panel. The grey slug turns to about 20% grey making the white text unreadable. I want to darken the 20% grey highlight.

Hmm, I’m not able to reproduce that. With my system preferences set to grey as the accent color and my binder set to black, the selected document color is a much darker and more legible grey. What version of Scrivener do you have and what OS version?

Scrivener 3.2.2
Mac 10.13.6
The top example grey that I changed from blue works great.
I just can’t figure out what the 20% grey is tied to in the second example. It looks the same as the manuscript edit background I use, but messing with that bg doesn’t effect it. As said, the highlight colour change is triggered by activating the manuscript.
Time to accept it’s what it is and move on.
Thanks for trying.

Well your Scrivener is up to date, but I am on 11.6, and given that the System Preference for accent color is at play, it’s possible the OS difference is causing the color difference.

Hmm, yeah that could be a peculiarity with 10.13. I regularly use 10.14, and it works as @JenT described above—you get a nicer dark grey in that scenario and the text is perfectly legible.

Does this happen even if you try boosting the background up a bit as I suggested, so that the selection colour no longer alternates as much between focused and inactive state?

AmberV…I have tried all the suggestions and nothing works.
FYI the change to 20% grey when I activate the manuscript is not a derivative of the original darker grey highlight. When the original highlight was blue the secondary highlight was still 20% grey.
I initially thought it was determined by the manuscript or synopsis background but changing them had no effect.
I’m surprised that if there is a link between the 20% grey highlight and my Mac OS that I can’t find it.

As said, I am pretty close to the point where I’ve got Scrivener groovin’ with my creative process.

Thanks for your help and thx JenT

Richard

I posted this before and was unable to solve the problem - hoping someone new might have an answer.
I have made a lot of mods to my workspace thanks to a number of members helping but this last issue is still problematic.
I am using the latest Scrivener and Mac 10.13.6

I have modified my binder so it has a black background with white text and set it up with Chapters (Folders) and Scenes.
When I select a Scene in my Binder that scene is highlighted in Grey. (See screen grab)
However, when I activate my editor by clicking on my manuscript the Binder Scene Grey highlight turns to a 20% grey.
And the Binder White Title Text is unreadable. (See screen grab.)

I have tried everything I can think of to find the source of the 20% Grey including changing the editor background colour but nothing works.

Does anyone know how to change this or what the source of the 20% Grey colour is?
Thx Richard


Is the grey is the system Highlight colour set in the General pane of System Preferences? What happens if you change that setting?

Disclaimer: I have always used the default Scrivener theme with my devices set to “Light”, and have never needed to play with such things, so I’m guessing. My binder highlight is 20% grey, I imagine, but the text is black.

:slight_smile:

Mark

One of the first things I tried.
As said, I have tried everything I can think of and I don’t get what/where the motivation for this highlight is.

I have merged what appears to be a rough duplicate of the original problem description, made in a new thread. The reason for not doing this is demonstrated above: someone else comes along, doesn’t know what all has been tried in the previous thread, and spend their time making suggestions already made.

In this case, there probably aren’t any suggestions that can be made, since as we determined above, it appears to be an issue with how macOS 10.13 handles this aspect of the design. It’s already flagged for review, in other words. I have no way to test or reproduce it myself however.

I still don’t understand how this action can be solely attributed to the Mac OS but ‘c’est la vie’ not worth wasting any more time.
Signing off.

I might have misspoke, I did not mean say it was solely a product of the operating system, but rather an undesirable interaction that we need to take a look at. It is certainly in part a component of how the OS works though (or probably more accurately, what happens when you compile software on a much newer system and run it on an older one, since it used to work fine), because on newer systems the result looks nothing like your screenshots and is perfectly legible.