<$Blank_Page> Not Working?

Struggling my way through this new program, Have been able to figure out about everything else, but I cannot figure out how to add a blank page.

Before, I’d add <$blank_page> to a scene, then mark “As Is” and poof, Now the code is showing instead of adding a blank page. The scene itself is marked “N/A” on the scene compile functions.

I’m sure it’s something easy.

I think it is case sensitive and needs to be all caps? <$BLANK_PAGE>

Even in all caps, still not working. Or it’s working in one manuscript and not another, even when the settings are exactly the same.

Are you sure the settings are the same? If you copy the compile format from the working project to the broken one does it work then?

Are these Front Matter pages?

Have you created a Front Matter Section Layout? (Probably one of the As-Is layouts is what you want.)

Have you applied the Front Matter layout to the relevant documents? (This last step is what tripped up another person experiencing this issue.)


It’s also not working for me. I didn’t change anything since Scrivener 2.x, updated my project for Scrivener 3, fixed a bunch of problems with the export profiles, but this stays in my output without being properly handled.

I wish the Scrivener 3 transition didn’t break my export presets (in more ways than this).

The Compile function in Scrivener 3 has been completely overhauled relative to Scrivener 2. It would be surprising if your existing presets didn’t break. As noted in my previous response, make sure that the documents in question have been assigned to an appropriate section layout.

If you haven’t already, you might want to take a look at our update guide for Scrivener 2 users, here:
literatureandlatte.com/scri … date-guide


Yes front matter pages, yes front matter has been applied. I finally got it to work by doing that AND making sure the front matter section had a page break between pages.

I got <$BLANK_PAGE> to work in Scrivener 3 (after using my S2 formats) in the following manner: -

  1. Created a new Section Layout called “Blank Page”
    - In File > Compile click {Assign Section Layout] button at the bottom of the Section Layout Pane

    - in the new pane that pops up "Choose Layout for xyz" -  double click on any one of the layouts to get the [b]Layout Editor[/b]
    - in the new pane (and note the side bar says "Section Layouts") that pops up click the [b]+[/b] in the top right hand corner to create the new Section Layout which I called "[u]My Blank Format[/u]" but it could be anything.
  1. In that same Layout Editor pane select the new My Blank Format

  2. Make sure all of the check boxes are unticked (Title / Metadata / Synopsis / Notes / Text )

  3. In the series of tabs under the top panel click through on the Prefix tab
    - in here type in <$BLANK_PAGE>
    - select the check box at the bottom of the pane that says Place prefix after title

  1. Hit [SAVE] - you’ll return to the previous pane.

  2. You can then assign this new My Blank Format layout to your Section Type Blank Page

  1. Check that there is a Page Break at the top of your My Blank Format layout.
    - note that you may need to change this so that it works on a page level instead of a Folder level - if so then…

  2. Double click on your My Black Format to get the Layout Editor again. Then in the side bar select “Separators

        - make sure your Section Layout still says "My Blank Format" - then unselect  the "[b]Use default separators[/b]" checkbox
       - Select from the pulldown menus "[b]Separator before sections[/b]" - Page Break
       - Hit [SAVE]
  1. Check that the text on the layout now shows the page break and the <$BLANK_PAGE> text

  2. You can hit [Compile] here - or save - (Option-click to reveal the SAVE button). Just make sure you save the changes you made here.

  3. Then you can create your blank pages and place then where you need them in your document in the Binder. I’ve only used them in front matter. So place them in your front matter section, and make sure that the front matter is added to the front of your document.

  1. To assign the “Blank Page” layout to your page. Select it in the Binder. Then in the Properties panel click through the icon tabs to get to the pane that shows the selected compile checkbox - make sure your new blank page is included in the compile process. Then you can select the Section Type “Blank Page” from the pull down.

Then go to File > Compile and generate your PDF. You should now see blank pages where you need them.

This may be more complicated than it needs to be… but after days working on it this is the only way it worked for me. I think that putting it in the Prefix on a unique page format ensures that it is in plain text .

I took the time to do a proper howto as I’m sure I’ll forget one day and have to search it up again myself.

But you know - wouldn’t it be great if there was a blank page type you could insert into the binder as easily as you insert a document? However now that I have a Blank Page format I can just assign this to any new document. Now I just have to work out how to get this new format type across all my old Scrivener 2 converted projects.