Block quote gets 'stuck'

While compiling a manuscript in an altered version of the Modern Layout, the first block quote-styled text gets ‘stuck’. The rest of the section (four paragraphs in total) is also formatted as a block quote, although the style is not attributed to the text.

Later in the document, there is another block quote, but there this does not happen. The paragraphs after the BQ are compiled normally.

Anybody an idea how to solve this?

I cannot reproduce anything like this in a simple test, using the stock Modern format. I created two test files in the binder, in accordance with your descriptions of the two cases. It is not clear whether you have tried using the stock variant yourself, to narrow down whether it is an issue with the content formatting or any modifications made to the Format.

Thanks for your quick reply! And sorry for being unclear on my part.

Yep, I also tried using the Modern stock variant, which led to the same result: an very long piece of text formatted as a block quote, although the text is not formatted as such. So I agree that it’s probably an issue with the content formatting.

I’ve tried finding anything unusual at the end of the block quote by ‘showing invisibles’, but to my eye it seems like a normal paragraph ending. I’ve added a screenshot of this.

It is very unusual as I’ve been using scrivener and block quotes for years without this ever happening. Perhaps it is in any way related to the long footnote at the end of the block quote?

Hmm, it doesn’t seem to be a particular issue with footnotes at the end of some styled text—at least in my simple test it came out looking fine in the RTF file. I also don’t see any obvious red flags (like line feeds or tabs instead of paragraph breaks). But speaking of RTF files, it might help to know what type of you’re creating (HTML, PDF, etc.), as that could make a big difference.

Well something I would try myself is to just strip out the styles in this section and reformat it:

  1. Take a quick Snapshot for reference (⌘5).
  2. Use Documents ▸ Convert ▸ Text to Default Formatting with the option set to remove styles.
  3. Using the snapshot in the inspector, reformat the section of text as needed and test it.

Thanks to much for the tips!
I’ve been exporting to Word (.docx) for proofreading. I’ve tried, like you suggested, getting rid of alle the styles in the document and making this particular paragraph a new block quote, but… no success. It still sucks the next paragraphs into the quote. Only in this particular document, the rest of the binder files have no problems.
I’ve also tried moving the footnote around, but no difference. Weird. :slight_smile:

Moreover, this happens not only with the Docx file, but also with RTF and RTFD.
PDF, however, formats normally, without the extra quoted paragraphs. Even weirder.

Then I tried styling the paragraph as ‘caption’, which did not have the problem, but then ‘centered text’ does such the next paragraphs in. But ‘Code block’ doesn’t.

Very strange, there is not even an obvious pattern with the results you got trying other styles. The ones that malfunction are a mix of Para and Para+Character type styles (at least by default, maybe they are modified?).

My guess is that the internal Scrivener code for where the style should stop is somehow misplaced. If so, there is probably no evidence as to how it got that way, but it could probably be fixed. If you’d prefer, I could take a stab at it if you send the project in to [our support address] Just leave the forum thread URL in your message so they can connect you with me.

Otherwise I could try and walk you through what I would try.