Block Quote, Markdown, Compile

I’m using Scrivener iOS for writing. Target is Markdown. I have an appearance file aimed at my desired Markdown format. (And I do imagine that I may have to compile on the Mac, but I’d like to get as close as I can in iOS.) So when I do a block quote, I paint it with the block quote format in iOS, and I prefix it with >, to signal to Markdown that it’s a block quote. Compiling, however, prefixes the > with a backslash, so the output looks like this:

>We’re doing good. The people who pay us to do good are in the enterprise. We should be in the enterprise strongly.

The backslash isn’t helping me. How can I convince Scrivener iOS not to insert it?


P.S. Excuse what appears to be bad english there. I mean good as in good things but that’s clearly not working. :slight_smile:

The Convert to Basic Markdown switch is what controls whether characters that are consider “special” by Markdown are escaped in this fashion. The idea here being that the switch is for people not writing in Markdown format, who wish to make use of it in some other application or as a form of dirt simple backup. It’s not as useful if you’re already using Markdown syntax, for this very reason.

Hi Amber,


But … if I turn OFF Convert To Basic Markdown, then I don’t even get double-spaced paragraphs, which breaks Markdown entirely. So I need CTBM on.

However, with CTBM ON, the > character is escaped. That doesn’t work in Markdown. Without the >, despite being formatted “block quote”, the paragraph is left justified and gets no >, so it doesn’t render in Markdown as block quote.

I respectfully suggest that "Convert To Basic Markdown should stop escaping the > character.

Thanks again,

The problem with disabling escaping is that someone else could end up with broken output if they’re using these characters for anything other than Markdown (which is the presumed use case for this feature). It isn’t designed to work in a hybrid fashion. You’ll find even asterisk, square brackets and anything else that might become unintentional Markdown, escaped.

If you are composing in Markdown it would be easier to double-space the paragraphs in the editor, to in essence write as you would with Markdown normally.

I must respectfully disagree.

Convert to Basic Markdown is the switch that makes Scrivener double space between paragraphs. That’s a good thing. Double-spacing manually is something we did back with the old Smith-Corona.

“Convert to Basic Markdown” seems also to be the switch that makes Scrivener escape the > sign. Otherwise it doesn’t.

It also escapes the brace characters, which are one’s MD alternative for putting in other such things, such as {:blockquote}.

That decision seems to be entirely backward.

Anyway I accept my fate for now, I guess. Anyway, not the topic for here, I guess. I’ll go file a request.


I don’t know what to tell you then. :slight_smile: I’ve been double-spacing paragraphs for decades and wouldn’t have ever considered it something awkward or old-fashioned. I also don’t understand the appeal of changing how you write depending on where you write, but that’s down to how I work no doubt. I’m typing just as frequently into a plain-text coding style editor (Sublime) as I am into Scrivener, and I freely copy and paste text between the two. As it stands I can punch F3 in Scrivener and have it load the current editor into Marked for preview. That would be a mess if I tried to mix Markdown with RTF conventions.

We all have our preferences of course, but I can only reiterate the original point: this switch is meant for people that don’t write using Markdown. The results are not meant to work with people who do, even a little.

But if they are functional, then wouldn’t an author who doesn’t use Markdown want to make sure that uses of the punctuation are printed for the reader or left intact for further processing (citation management software uses curly braces for placeholders), instead of being interpreted as custom classes or whatever and stripped out of book?

Well, you’re conversing with one of two people that would be answering a wish list post. :slight_smile:

/me checks back to be sure he hasn’t said anything insulting … :slight_smile:

I agree with Ron, there needs to be a way to export Blockquotes. This is a big deal, perhaps an option/switch during export, when activated will match a Blockquote Style with the Blockquote Markdown. The same way Headings are matched with HTML Headings.