Block Quotes in Formatting

I have read all the threads on this but I still cannot figure out what I’m doing wrong. I had no Block Quote setting in Formatting, so I set out to create one. I modified some text in my project using “increase indent” until it looked the way I wanted it as a block quote. Then I highlighted that text, chose, Format > Formatting > New Preset From Selection, and created a new format called “Block Quote.”

But, when I select a paragraph and choose the Block Quote setting, it fails to convert the text. Not only that, but the original text I configured the way I wanted as a block quote is converted back to text format when selected. ??? What am I doing wrong???

Hope you can help. I feel like a dunderhead.

Macbook Pro OS 10.8
Scrivener 2.4.1

It sounds to me as though you might have some formatting corruption in that file. Was it pasted in from another program perhaps? I would try wiping out the formatting in the document (copy the text, create a new file, paste using Edit/Paste and Match Style, rebuild necessary formatting by hand—the split editor feature can help a lot with this as you can keep the originally formatted file alongside the new one).

Thanks for your reply. It was not pasted from another program, but is native to Scrivener (where I do all my writing). I will try your suggestion and report back.

By the way, when I select “Preserve Formatting” the chosen text converts to a block quote format (with the dotted line and shaded area). That’s the only way I have been able to make it stick.

I did as you suggested but am still having the same issue. No matter how I format the section (using decrease indent), and copy and paste matching style, the formatting is lost and the selected text returns to its former margins. I have tried this in various projects and the result is the same. Also created a new (test) project and copied and pasted a section of text–same result.

I’m stymied.

P.S. Are there files in Mac’s library > application support that I can toss out or alter to fix this?

Okay, I might be misunderstanding something then. What is the precise sequence of steps used—every button and menu command clicked from an empty text editor to a paragraph that lost its formatting because it was selected:

I cannot myself think of any events that would cause the formatting of a paragraph to change, merely because it had been selected. Selection should be a passive event in the software, until you run a command that takes a selection. But if you have a reproducible condition that does cause that to happen we’d love to hear about it as it sounds like a new bug.

Well, you could trash the Styles.plist file in application support. That would just reset your formatting presets to the factory default. I’m not sure if that would help anything though given the context of the problem.

That’s very odd. Assigning “Preserve Formatting” should do absolutely nothing to the formatting of the text. It will draw the blue box around it, which indicates the compiler will no longer adjust the formatting of the text within the box, but that is it. You say you are seeing the text become block indented when using [b]Format/Formatting/Preserve Formatting[/b]?

Maybe you’re talking about compiling though, rather than anything going on in the editor. If you mean to say your indented text is no longer indented after you compile—well that’s another thing entirely, and you’ve already chanced upon the best solution to the problem: include Preserve Formatting as a part of your formatting presets if they need to survive compilation.

Of course another solution is to just switch off the “Override text and notes formatting” in the Formatting compile option pane, which will make Scrivener work a bit more like a normal word processor.

Good morning… Okay, here are the steps I’ve taken:

  1. Type (in this case) a book review in the editor.

  2. Select passages from the book that I intend to use as examples of the writing and paste them in the editor.

  3. Select one of those passages and, using the Formatting > Text > Increase Indent, create quote block passage.

  4. Highlight the edited quote block and go to Formatting> New Preset From Selection> Enter name (Block Quote).

  5. Highlight another passage from the book that I wish to be in block quotes > Formatting > Apply Preset > Block Quotes (from my earlier creation). Nothing happens, the passage retains the margins of the original document.


  1. If I select the original passage I used for my New Preset From Selection…and go to Formatting > Apply Preset > Block Quotes, the passage changes back to the default margins of the original document.

In other words, I cannot make a Preset Block Quote that will convert a passage into block quotes nor will one I configured manually stay that way.

Here are the

Thanks very much for providing additional details. I think a part of your post got cut off though, it ends with “Here are the…”, after the screenshot.

Nope. That “Here are the” was a cut and paste problem when I moved the screen shot to the bottom of the page. The post ends with the screen shot.

Okay, I note in step two you mention copying and pasting text from the book. I’m assuming this is an external source, which software is the book being pasted from? Since the preset is being created from that text, perhaps there is something in it that is messing up the formatting engine. Something you can try to see if that is the case is to use a different method of pasting as a test.

  1. Create a new file in the binder (just to be safe).
  2. Use [b]Edit/Paste and Match Style[/b] instead of the standard [b]Edit/Paste[/b] command to bring in the sample text. This will basically treat the text as plain-text, stripping all formatting from it.
  3. Indent as you have been, create a preset, and see if it works better.

And to reiterate another point, I think you will do better if you also select the paragraph and use [b]Format/Formatting/Preserve Formatting[/b], so that the text you mark is protected from compile reformatting. That will get saved in the preset.

Hi again, Amber. I Tinkered around with the text and finally figured out what (I think) happened.

The quote I wanted to set in “Block Quote” I had copied and pasted to Scriv. from my Mac Kindle App. or the Kindle home page on the Internet (I can’t remember now).

Anyway, once I copied and pasted the entire text to iTextExpress, changed it to plain text, re-pasted it to Scriv., the preset “Block Quote” now works.

So I think, as you suggested, that there was a conflict with the pasted quote from Kindle.

Bottom line: IT’S FIXED. Thank you for all your attention. Scrivener really is the The Best writing app and the tech support is outstanding. :smiley:

Great! Glad to hear you got it fixed. I’ve been trying to reproduce the problem with the Kindle software to see if it is something we can fix for future users as well, but unfortunately I’m not getting the same result. It could very likely be something dependent upon the source book’s formatting itself, though I can’t think of what. At least you have a way of getting around it now. Remember that Paste and Match Style command I told you of is basically like running text through a cleaner, too, so you can skip that step in the future if you use that instead.

Great, I’ll remember that in the future. I really have no way of knowing what went wrong, but glad it’s fixed. Again, thanks so much for your patient help.