Blue line appearing under text

I’ve noticed since the last major update an annoying blue line appearing while I work under text–like the red spell check line we’ve seen for years, but it’s blue. It appears to flag grammar. I don’t have grammar selected with spelling, or anything I can find that would give me this blue line appearing all the time.

Is there a simple fix to remove this feature? I even turned off the global Mac OS X spell check while you type, fishing for solutions. Thanks in advance.

This sounds like the line that appears when you’ve allowed OS X’s spelling correction to correct a word, and the line appears so that you know you can change it back (I think). It’s part of the OS X text system, though, and nothing that Scrivener has added, and as far as I know Apple has provided no way of turning it off.

All the best,

Why does Apple do things that are so annoying? And to make matters worse, why do they force everyone to use the new features by not allowing them to be deactivated? Glad I haven’t upgraded. Lion suits me fine.

You should be able to turn off autocorrect in Mavericks, in the Text tab of Keyboard from the system preferences.

I believe this can be disabled by turning off “Correct spelling automatically” in the Text tab of the Keyboard system preference pane (that is where it is on 10.9 anyway). You may also need to switch off “Correct spelling errors as you type” in Scrivener’s Corrections preference pane. I’m not sure if that is all you have to do (or if all of that is necessary), but I do know that I got this wretched thing turned off back when it came out, and I haven’t seen it since anywhere on the system.

Well that’s a relief. I wish I could turn off mission control and revert to spaces.

I have found that TotalSpaces works really well (at least on Lion and Mt. Lion; I haven’t updated to Mavericks yet and gotten the new version, though I will once I’m forced into the new OS). It offers basically everything Spaces had and then some, plus without the annoying bug my Snow Leopard machine is prone to, where switching spaces frequently disables the keyboard (yeah, gotta love it). It also allows you to get rid of that wretched nausea-inducing animation when switching desktops, which is what pushed me to find a third-party solution in the first place. With that it gave me back my beautiful, beautiful grid, so I am happy. Stephen, the developer, has always been polite and responsive to bug reports as well, in my experience (though I haven’t posted any since back in the beta days).

Thanks MM!

Yes, sorry, I should have clarified: I assumed that the op wanted spelling correction turned on (there’s no way to get rid of the blue lines if spelling correction is turned on, as it is a new part of that).

As for Mavericks in general… I really wish Apple had spent six more months on it. I haven’t seen so may issues with an OS X release for several years.

Thanks much. I happened upon this also, actually (don’t know how I found it) and I haven’t seen the blue underline lately. Thanks for the many replies. I knew that Scrivener wouldn’t force that line on me. Figured it was a system-wide thing. And btw, I’m still on Lion, so it must not be a Mavericks-only issue.