blurry resolution/weird scaling on 1920x1080 display

Hey guys! Maybe there’s an easy fix to this and I just can’t figure out, but here’s the sitch. I got a new computer a few days ago and downloaded Scrivener, and when I opened it to do some work I realized it’s one of the apps that appear blurry on this display. And it kinda looks like the words a little more bold than usual, too. I’m wondering if there’s a fix for this, because I’m not sure I can use it without hurting my eyes (which I already strain enough) and getting a headache. It’s not terribly blurry, but it’s not sharply clear either. I put it alongside Word for comparison. It’s actually worse irl than it is in the screenshot; if you right click and view it alone at a bigger size it’s easier to tell.

Also, the font in the binder and in the toolbars appear a lot smaller than they used to. I know I can adjust the zoom in the editor (I used to have it at 115% but upped it to 140%) but can I do it for other parts of the program? I searched the user manual for the words “scaling” and “resolution” but didn’t find anything that helped.

It all looked fine on my old Dell Inspiron 3521, which was 1366x768 at 100% zoom I believe, but now I have an HP ZBook 15 with 1980x1080 at 125% zoom.

And yes, I have the “fix apps so they’re not blurry” toggle on and the machine has since been restarted. Unfortunately, it doesn’t work completely. Scrivener isn’t the only app that looks blurry now.



Question: Is your monitor connected via VGA or dvi or hdmi? Or is there some kind of conversion going on? In general, output is digital and vga is analog so VGA output onto digital screens is sometimes fuzzy. Of course, if it is a built in laptop screen this isn’t an issue.

Is it fuzzy at 100% instead of 125% There is no problem running scrivener on 1920x1080 screens or 1920x1200 screens (I have both), so this issue could be on Windows scaling which is done very poorly and Scrivener’s older programming framework (updated with version 3). Knowing this let’s us determine what is causing the problem.

Have you tried other fonts to determine if it is fuzzy with some fonts but not with others?

Perhaps someone who is testing V 3 can tell us whether the scaling transitions are improved in V3 compared with V1.9?

Hi! Thanks for replying!

Nope, it’s just the monitor on my laptop. I’m not connected to a TV or another monitor or anything.

Some fonts seemed a little clearer. It seemed like the fonts that are normally thicker are worse than the ones whose letters are thinner. Or maybe it’s just less noticable because they’re lighter.

I reduced the scale to 100% and the print did look clearer, I think? I went up to 150% in the editor. But then everything is so itty bitty tiny! I can’t keep it at 100%, it’s just annoying to have everything so small. It’s hard to read the binder and menus.

It won’t surprise me if it’s just that Windows has crappy scaling. I’ll keep using Scrivener for small projects, but I won’t be composing any long documents in it for now.

My Scrivener is up to date, for reference. Version: 1.9.9.0 - 03 Oct 2018

On Windows 7, 8, 8.1, and 10, I have used OS-level scaling at 100% and editor scaling within Scrivener at 135% and that seems to work for me. I’ve used these settings on a variety of displays, including a monster 3440x1440 Dell ultra-wide, and my display stays crisp. Hope this works for you.

Just about everything in Scrivener is size adjustable, including the binder. I use 100% for Windows and 150% in Scrivener editor, but have adjusted the fonts for the binder Tahoma [16], comments [Arial 14], scratchpad editor Georgia [20], corkboard Georgia [14]

There’s no reason that stuff should be small.

Can you tell me how to do that, then, please?

I’m sure all you need is a single example

From tools/ options Appearance
Choose fonts
Now there’s lots of stuff. Select what you want.
The example above shows binder. Change the font with Select font

Change whatever you like: Menus, document notes etc.

I also ha d this problem but i was able to fix it with the specific programs settings that had this issue particularly.

Note down which specific programs have the font problem.
Right-click on the program icon (not the shortcut) and choose properties.
Click the “Compatibility” tab.
Check the box labeled “Disable display scaling on high DPI settings”.
Restart the program mybkexperience.

YES! Thank you! Finally a solution! I couldn’t do exactly as you said because apparently my settings are different or something, but for reference’s sake, this is what I did:

with the program NOT open
bring up the start menu
scroll down to scrivener, right click on it
hover over more>then select “open file location”
in the window that opens, right click on the scrivener icon
go to properties, then the compatibility tab
click on “change high DPI settings” button
check the box for “Override high DPI scaling behavior. Scaling performed by:” and select “application”
click OK, then apply and OK again
open scrivener and go to work without getting a headache! yay!
thanks Priscilla334!

I had a similar blurry problem on my 3200x1800 display. The fix above does resolve the blurriness, but now all the icons, taskbars, and pop-up windows are miniscule. Can anyone suggest a solution? Thanks in advance!

When you went into the properties and checked the box to override high DPI setting, what did you select in the dropdown, application or system?

Application. It was the only setting that solved the blurry (actually pixilated) problem.