Bookmarks glitch

I’ve been participating in the Beta, and had a project with some internal project bookmarks. When I loaded the project into the release version of Scrivener3, my project bookmarks weren’t displayed properly in the inspector. No titles were visible, and the icons were squares with question marks in them. Some of those bookmarks were to folders with custom icons (the first was the supplied blue spiral notebook icon).

It was easy to fix though; I just loaded a document’s bookmarks pane (which happened to be empty), and then loaded project bookmarks again, and everything was right with the world.

Nothing has changed in this regard in the release version since the latest beta.

Could you please provide the necessary steps to reproduce the issue?


I’ve tried several things, but nothing triggers the issue once I fix it again. Short of restoring my system from backup, I don’t think I"ll be able to reproduce this.

I’ll keep an eye out for the next point release, to see if it returns, and create a backup before fixing it.

I had the same issue with my project bookmarks changing into squares (maybe rectangles) with question marks in them. It happened one day when I opened Scrivener with the project bookmarks pane open. I closed and re-opened Scrivener, and they were still question marks. I fixed it by following RDale’s instructions to switch to the document bookmarks then back to project bookmarks.

This is Scrivener 3.0.1 (966).