Brazilian accents

I’ve been testing Scrivener for a few days and am pretty amazed by how useful it can be for my projects.

But there’s this issue with brazilian accents wich can make me drop it:

When in scripting mode, I simply can’t use some accented letters (I don’t know if it will print right in this forum):

ç (“c” cedil)
á, é, í, ó, ú (acute vowels)
ü (uml)

I can, however, script properly the circunflex, grave and tilde vowels (as “ê”, “è” and “ã”).

When I paste text with this issued characters, it shows up right.

How can I make this work?

Hello Edgarcn…
Unfortunately I didn’t come here to solve your problem, but to ask for help for the same difficulties…
I really thought I couldn’t use any accents at all, but after reading your post, I checked out that I couldn’t use only a few of them, however, the most common in our language.

I imagine that people that write in other languages that also make use of accents, such as spanish, might be having the same problems, so, there must be some one out there that knows how to fix this.

At the moment I’m trying 4 programmes, including Scrivener, and although I prefer Scrivener, this is keeping me from making the decision rightaway…

Help, please!


I guess it would help to know what language keyboard you are using … I use the British English keyboard and can enter all the accented characters available in the system – UTF 8 – in the usual way.

The Brazilian Portuguese and/or other keyboards might have the accented characters assigned differently, but unless Keith has re-mapped those keys or key combinations to other things, it would seem strange to me that you can’t, and I wouldn’t have thought Keith would have done that.

But let us know which keyboard you are using.



I write both in English and Spanish (in which I have similar needs), so I have both keyboard layouts setup under System Preferences->International. Additionally, I have selected “Show input menu in menu bar.” Whenever I want to switch keyboard layouts, all I need is to select the right language. I wish the spelling dictionary would have that option too.

I do neither use the Scriptwriting Mode nor (normally) letters with cedillas etc.

So forgive me if my suggestion is totally stupid – can it be that the Courier font that comes with the Scriptwriting Mode does not contain these “special” characters?

I was trying to find all fo those info to tell you, but I don’t know where to look for them all… what I can tell you is that I do have that little flag on my menu bar with some languages, including my onw which I selected upon installation… I never use it though because it won’t let me use accents either. So, I had to install another keyboard layout - US. International… and that’s what I use so I can have accented letters such as á, é, í, ó, ú, â, ê, ã, õ, etc…
I hardly ever change keyboard layout so, I use US International al the time but when using Scrivener… no accents! I mean, some do appear… but á, é, í, ó, ú do not.

Oh, and my keyboard is US also.


I can place all of those characters fine in both scriptwriting and prose mode. And as the text editor is an OSX function more that a Scrivener one, it sounds like the problem is indeed either to do with keyboard functions, or the typeface you’re using for script.

How do you get the cedilla, for example? On the US keyboard, you just press alt-c, thus: ç. Is it different on Brazilian keyboards?

I tried to replicate the problem here and it seems to me that those characters don’t work only when you are typing in all caps (when Scrivener is configure to format, e.g, a Scene Heading, in all caps). When I write in small caps, I can use all the characters.

When I use MS Word to write all caps (by using caps lock pressed), I am also unable to use some of the accented characters. But, if i type the capitalized character holding shift, I can place the accent.

So, it seems to me that it can be a problem related to the option in Scrivener to automatically capitalize some styles, as scene heading.

I hope this help.

When you say “brazillian keyboard” do you refer to the physical keyboard?

I use an US Keyboard with US International layout.

That’s what I’ve always used both with Mac OSX and Windows.

To accent á é í… I use '+a, '+e, '+i, …

ç would be '+c

Well, I think I can say it definitely has to do with keyboard layouts. I myself, as every Brazilian switcher (win->mac), have installed Rainer Brockerhoff’s US - International keyboard layout (, as it is the only one that mimics the behaviour of accentuation we’re used to when using international keyboards. For example, for the “ç” we use the '+c, for the acute accented vowels, we use '+vowel. Of course, we can use alt+e, then the vowel, but it requires one more keystroke and, most importantly, it’s not the way we’re used to and this is an issue when we have to use other computers. Plus, this only happens with Scrivener in scripting mode. Throughout the system (everywhere), Brockerhoff’s KL works perfectly.

Any thoughts?

I guess I just won’t keep trying, unfortunately… I really like this programme, but there’s no point in keep trying to make this work when I got only a few days of trial left and all other 3 programmes I’m also trying have similar features and do accept accents.

IF anyone out there can shed some light on this matter, I’d be forever grateful!


Thanks again!

Scripting mode doesn’t do anything particularly weird with accents or overriding anything. It would cause issues when auto-capitalising, that is true, but you can just turn off auto-caps and do it manually. If it is not to do with capitalisation, I am at a loss…

I have found the solution.

Simply go to the MENU Scrivener/Preferences… then choose Typography and de-select option “Activate Typographers quote”.

It works wonderfully now with US International Keyboard for accented characters.

Enjoy it!

It works!!!

On a related note, bear in mind that accents don’t really work if you have caps lock on while trying to add them. You have to have caps lock off, hit option + the accent you need, then shift + the letter you need.