British English for the whole document

I’ve tried everything I can think of. I’ve tried all the options I can find here, and online, and nothing seems to allow me to have British English while I’m writing in Scrivener. I don’t just want it for a single section, I want it for the full document.

My computer’s default language is British English. I’ve even disabled all other languages to no avail.

Anyone have any suggestions?

What versions of OS X and Scrivener are you using?

What language is it defaulting to if not British English?

Are you changing the language in OS X System Preferences? … scrivener/

What language is set in Scrivener > Preferences >General > Language?

You can always view your entire manuscript in Scrivenings and then select all the text (CMD A) and set the language for all the documents at once (CMD SHIFT A > British English).

I’m on an old Mac running OSX 10.6.8, Scrivener v2.6 (no updates available for it).

US English (I think). Definitely not either the British English or English (Ire) that I tried.

Yes, I tried that. Several different iterations.
Scrivener > Preferences >General > Language is at “default”.

I finally got it to work, but only by deleting all other languages from the OSX System Preferences. Even with British English as the top pick, it won’t do it if other English variations are listed. I have to get rid of all the others.

ARGH!! I thought it was fixed. It acted like it was fixed, but now it isn’t.

I’m not sure now whether the “Look up in Dictionary” function under Writing Tools is part of Scrivener or not? If it is, that’s where my problem lies. It only lists New Oxford American, Apple, and Wikipedia as possible dictionary sources. There’s no options to add a new dictionary, and the only other ones that aren’t selected are Japanese, and no use to me.

I have deleted all other languages from my Mac’s settings except British English.