Bug beta: issue in Project Replace, unable to write a non-breaking space

I am trying to replace all regular space after em-dashes by non-breaking space, but when I open Project Replace, I can’t write a non-breaking space in that window. Instead, a regular space is written. I tried copy paste a non-breaking space. I also tried shift+Ctrl+space bar, but nothing works. And in that window, we don’t have access to the character map…

I am using Windows 10 on a laptop.

Has anyone noted this problem? Is that normal? Will it be fixed?

For some time I have had similar problems searching for and replacing non-ascii characters. Newlines also seem to be problematic.

I’d also like to see this resolved. I prefer to use three periods with spaces between them to using an ellipsis character, and to prevent it from text-wrapping in weird places, I use non-breaking spaces in the final document. However, I can’t find a way to quickly replace any ellipses I created with regular spaces using any of the Replace options, so I’m faced with finding and replacing every such ellipsis in a 230K+ novel manually, which seems ridiculous. I’ve tried every way I can think of, but none of the search and replace options recognize the non-breaking space, that I can see. They see them all as regular spaces.

Is this on a list somewhere to be addressed?

Okay, I just found a solution. I’m using Scrivener 3 for Windows. Using CTRL-F for Find and Replace with the entire document folder selected, I used the Alt code for non-breaking spaces (ALT-0160) in the “Replace” field, and it finally worked. I’m glad. I just upgraded from Scrivener 1 this morning in the hopes of addressing this problem. Since this was the only way it seems I can do it, that still seems very specific and finicky and like it should be easier, but I’m thankful to have found a solution. Hoping this helps someone else.