[Bug] Bad spelling corrections for dict "Norway-nb" and special characters

I just came over from the Mac version of Scrivener, and cannot remember reacting to the spellchecker when I write Norwegian text. But the dict used on the Windows version at least is seriously lacking, e.g. the correct “forstod”/“forsto” (“understood”) is missing, or at least shows up as errors.

It also messes up capitalization of special characters æÆ (and maybe øØ and åÅ, but dont have an example). See attached image. The word should be correct, but the dict offers the uppercase version of the letter as a correction to the word, which at least is completely wrong.

Beyond this, let me also add that the program appears to work really well (:

(Edit: small fix in headline)
Spellchecker error.png

From what I understand, the spell-checker in the Windows version is Hunspell, and the spell-checker in the Mac is something else (don’t remember offhand).

They use different dictionaries. The dictionaries are not created by L&L; they merely selected them.

Other dictionaries can be added to Scrivener (second post in this thread: [url][JH] Dictionaries - Portuguese - #7 by ricardofdiogo]). A number of sources for hunspell dictionaries are available, and one post (in this thread: [url][NB] On dictionaries... - #3 by rwfranz]) lists several sources.

I don’t know Norwegian, so can’t really offer any comments on the quality of any of those dictionaries. If you find another source for hunspell dictionaries (even if limited to just one language), please reply to that list of sources and mention its URL.

Let me bump this on up - the problem is still present 2 years later. Some words with Norwegian lettesr æ, ø and å that are spelled correctly shows up as wrong by the spellchecker.

Portuguese had the same issue, and a better dictionary was found. Is there a better open-source dictionary, Hunspell-compatible, for Norwegian?

Found one myself. It’s kind of old (2008), and I’m checking to see if it works.

I couldn’t reproduce the issue. However, some comments:

The dictionary Scrivener uses is about 119k words. That dictionary includes approximately 189 common abbreviations, and may not have your words included in it. I pulled a few Norwegian words from the nb dictionary, with those special characters, pasted them in a document, and spellcheck did not tag them as badly spelled (these: Abelvær, Abildsø, administrasjonsspråk). Just to make sure the spellcheck is working, I tested them also with an English dictionary loaded, and it tagged them as misspelled. So spellcheck was working.

I also tried a bigger nb dictionary, and they worked fine there. I looked at the nn version, and it seems to be similar. Everything should work.

While there shouldn’t be an issue with your font, there may be. A different font may give you different results. This has been noticed in some applications, that some characters in some fonts are not recognized correctly in spell check. This is not the fault of the application, but of the font itself (faulty encoding, or possibly mislabeled encoding). Sometimes it is the fault of the application, but I suspect not here. FYI, I use Noto Serif, but any font with a Western encoding (ISO8859-1) should be fine.

What else could cause this issue? I have no idea. I don’t know of any system setting that would cause this, although there could be one.

I did find a dictionary with 322k words, and another one with 215k words. They don’t have those abbreviations in them, so far as I could tell.