Bug? Em Dashes and ellipses

I hate smart quotes so I have the compile option of dumb punctuation checked in my compile settings. This also resulted in my em dashes and ellipses being converted back to two dashes and three periods respectively.
My suspicion is it’s a compiler bug. If you removed the option to only fix the quotes etc and leave the em dashes etc alone I’ll be one disappointed user.



The compile option is by design and matches the Mac functionality. If you want only certain characters replaced, you can happily use the compile project/format replacements.

Okay so I have to do this for every project?
Nope Bye Scrivener I’ve been a long long time user, I even bought a mac to use your software yet you remove options that are in the old version and make the compiler so complicated it is very very troublesome to use.

As much as I love you this may be the end of our relationship.
This was the perfect solution (screen shot is from 1.9) I don’t understand why you want to over complicate something that didn’t need to change.

With all my respect, if the inconvenience of typing 4 characters within the replacements section, makes you quit on Scrivener, most likely you are not using the full potential of Scrivener.
You can create a global compile format with the replacements and use it in all projects.

As I wrote above this option has been adjusted to match Mac, which has always used only one tick to control this conversion. Sorry for the inconvenience, but there is a quick solution for your problem, so Scrivener has not left you behind.