[Bug?] Font changes upon new paragraph/hitting enter.

As the title says. I’m using the newest beta version and the font keeps changing upon new paragraph. I like working with Calibri, but it keeps changing to Sitka Text. The size remains the same.

I’m not sure if this is a bug or there’s a feature I’m missing that explains this behavior. It’s not program breaking, just distracting.

How are you changing the font to Calibri? And are you using a Style by any chance?

Just by going into the font drop-down menu on the toolbar I believe it’s called? And no I’m not.

I forgot to mention that this project was created originally using the Mac version of Scrivener 3. I’m no longer able to use a Mac so I’m using the Beta of Scriv 3 for Windows.

Not sure why, but selecting all the text again and changing it to a random font before changing back to Calibri fixed this issue. Just thought I’d update this.

Odd. Please let us know if you experience this is again.

In the meantime, I suggest that you go to File > Options > Editing > Formatting if you haven’t already and change your default text font from Sitka (the new auto default) to Calibri so that all your new documents will start off in the correct font. This will hopefully eliminate the need for the workaround you’ve found.

I am experiencing this, and cannot get it to change. I have successfully set my default formatting to the font I want, but when I press the return key to get a new line, it reverts back to the old font. It is extremely annoying and I need a fix!

I’m assuming by this that you’ve set the font in Options > Editing > Formatting. Are new documents starting with that font, retaining it for the first paragraph, but switching to a different font after you hit Enter? Or have you changed the font within an existing document through a different method?

Is your document accidentally set to script mode? Check Format > Scriptwriting > Script Mode and deselect it if it is enabled, then try resetting the document text to the default formatting (under Documents > Convert) and see if it sticks. In script mode, the script settings determine the font and other formatting for each element, so there pressing Enter would be restoring the new line to its script-defined formatting rather than your general defaults.

I’m having the same problem with the font changing to New Times Roman when I hit a carriage return!!! Arghh!

The older suggestions no longer work now that the entire program has been redesigned, with a 500+ page manual, in which I cannot find anything because there is no indexing! For instance there is no longer a File–>Options–>Editing… path, at least not on the Mac version.

I just want to change the default font, not across all files but this one in particular so that I can actually write without having issues with both tabs and fonts.

Thank you.

  1. Since you’re in the Windows forum, your Mac problems are of no relevance here,

  2. As a Mac user, I assume you should know that in the Mac, such things are in the Preferences system (which Windows doesn’t have, hence Options …)

  3. If you only want to change it for one project, go to Project > Project settings > Formatting and set it there! (Windows is no different in that).