Bug: Regular/roman font displays as italic

Hello L&L and community,

I’m encountering a bizarrely specific bug. My favorite font to use the editor window, Crimson, displays incorrectly in Scrivener. The font works correctly in all other applications on my PC, including LibreOffice, Photoshop and Jutoh. All other fonts I’ve tried in Scrivener work fine.

When I first opened one of my projects in the beta version of Scrivener, I noticed that all roman/regular text in the Crimson font was displaying as semibold, even though I had applied no semibold formatting. Thinking it was a problem with the font files, I downloaded the latest versions of Crimson and reinstalled.

Now all roman/regular text in Crimson displays as italic! The only way to get roman to display as roman is to uninstall all styles of Crimson except regular, and then I’m stuck with faux italic and faux bold. (Not a long-term option, as I use this font for design work in my author branding and need it fully installed on my system.)

The bug happens on existing projects that were already using the Crimson font and new projects if the Crimson font is applied. It also happens on both my desktop and my laptop.

I know this isn’t likely to affect very many users, and the devs have more important bugs to address. But in case anyone else might be having trouble with their favorite font, I decided to go ahead and post this. Converting all your documents in all your projects to a new default font without disturbing any special formatting is admittedly a daunting prospect, even with Scrivener’s robust features for doing that.

OS: Windows 10 64 bit
Scrivener beta version: 2.9.9.20

Steps to reproduce:

  1. Download and install the Crimson font family.
    Github: https://github.com/skosch/Crimson
    FontSquirrel: https://www.fontsquirrel.com/fonts/crimson

  2. Open an existing Scrivener project or create a new one.

  3. Change any text to the Crimson font and set the style to Roman (Regular).

To anyone reading this far, thank you for your time. :slight_smile:

I did that. I don’t see bold or semi-bold, but italic.

[attachment=0]crimson.jpg[/attachment]

Thank you so much for taking time to test this out! :slight_smile: So you’re getting the italics bug too, even on text that isn’t formatted as italic? Since reinstalling the fonts, the semibold bug isn’t happening anymore on my PCs, either, I just keep getting italics.

Can I ask whether you used the font files from Github or FontSquirrel?

FontSquirrel OTF.

Well, it appears the issue is with the FontSquirrel files and the current release on Github.

I installed this pre-release version:
https://github.com/skosch/Crimson/releases/tag/fonts-october2014

And the issue appears to be gone.

I still find it really strange that the bug only appears in the Scrivener beta and not any other app, but I’m just happy to have my font back.

Thank you so much for your time testing this out. I guess I should have tried every single release from Github before posting a bug report! I just assumed the current release would be less buggy, not moreso.

Do you have any other apps installed that are using the same Qt version libraries that the Scrivener beta does? IIRC, Scrivener relies on the Qt libraries for font handling, so you could have an interaction of a bug in that version of the Qt font library with a bug in the font data that you used.