BUG REPORT: Wrong link when compiled ti ePub file


According to the Scrivener manual I have created a custom Table of Content (ToC) for my ePub e-book. I did like described in the manual:

“If you wish to produce a custom ToC for your e-book, a better method will be
Edit --> Copy Special --> Copy Documents as Scrivener Links, since the menu command
to copy as a ToC will insert page numbering tokens which are meaningless in an
e-book context.”

Problem: The very first link in the ToC links to the end of the document right before the ToC and not to the document I have actually linked to. The link works fine in Scrivener. The problem occurs when I compile to ePub format.

I have tried to delete and on-do the ToC a dozen of times, and I have unlinked and linked, deleted and re-written the text over and over again with no result. I have also moved the ToC to different places in the binder and the result is the same: The first link links to the previous page, whatever that might be at different locations.

If you could fix this or tell me if I am doing anything wrong, it would be very appreciated.

Thank you so much in advance.


As a quick test, what happens if you compile using the PDF option (the links should be clickable). If they work there, then that will determine whether the problem is going on with how ePubs are created specifically, as opposed to a general problem with the link (it doesn’t sound like there is a problem with the link itself).

Thanks for the reply :smiley:

I did the pdf-format, and the link works here.

Conclusion: Something goes wrong when formatting into ePub …

PS. Maybe I should add, that I have tried to move the document I want the link to open, to the spot right before the document with the ToC (as the link automatically opens the previous document no matter which one). This partly solves the problem, except that it opens up the end of the document and not the beginning. And as it contains 1600 words, it is still not a good way for me to come around the problem.

Okay, that could make things a little easier to figure out what is going on. One of the advantages to ePub is that it is an open format based on simple web technology (with a little extra to describe the book’s meta-data and how the various web files are supposed to fit together). So you can use a tool like Calibre or Sigil to open the ePub directly and see exactly what the link is pointing to. If you could compare the first ToC link to the rest, is there anything different about it within the “href” portion of the link?

If you’re not familiar with this stuff, I’d be happy to take a look at the project for you, or even just the compile ePub, but obviously having the thing that makes the ePub will help the most. If that’s agreeable, zip up a copy of the project and send it to our [support address](literatureandlatte.com/suppo … tion-email), flagging this forum thread URL so that whoever gets it can forward it to me.

Hi again, AmberV!

I am sorry for my late reply, but I have been down with the flu.

Thank you for being willing to take a look at my project. I have tried to look at it myself, but I give up.

I have just sent an email to the support address with two attached files: both the scrivener file and the ePub file.

I will be looking forward to your answer.

Thanks! I got both files and did some looking about. Unfortunately what you are describing doesn’t happen for me, even in the ePub you provided. I loaded it in Sigil first so that I could see the code, and the first link in the ToC page not only correctly goes to the right section, there is nothing strange about its HTML either. I tried in Adobe Digital Editions, and clicking the link took me to the proper file, not the dedication page. I then tried Calibre and iBooks and they worked fine as well.

So I’m wondering if this maybe a problem with your e-book reader rather than the ePub file itself? Which one are you using to test the book?

Thank you so much for your reply. And once again I apologize being late to reply back to this thread. I thought I would get an email, so I didn’t check into this forum here until now.

I am using the Firefox ebook reader plugin.

Could this be the one causing the problem?

I only have a Kindle myself, but I am going to publish the book in the ePub-formate as this is the common formate here in Denmark.

If the problem is the Firefox plugin, can you then recommend another free way to check the file?

Once again: Thank you SO MUCH! I am so grateful for your help :smiley: :smiley: :smiley:

No worries, there is a subscription link at the very bottom of this thread that will sign you up for e-mail alerts. You can also switch it on globally for any threads you participate in, in the user control panel link at the top.

The three tools I mentioned in the prior post are all free, and in fact iBooks is a stock Mac program. Adobe Digital Editions is particularly useful in that most hardware ePub-based readers (such as Sony, Nook and Kobo) use that engine to display books.