Bullets not indented after compile

Hi All,

I seem to be having a problem with the indentation of bulletpoints after I have compiled my document. I’ve looked on the forum, but could not find any other references with a similar problem.

The problem I have is that my bullets look correct in Scrivener (kinda at least because the forum editor does not add the bullet, I did this manually):

  • It is a long established fact that a reader will be distracted by the readable
    content of a page when looking at its layout. The point of using Lorem Ipsum
    is that it has a more-or-less normal distribution of letters, as opposed…

  • It is a long established fact that a reader will be distracted by the readable
    content of a page when looking at its layout…

…but after the compile it looks like (the … is just a space/tab, this editor for some reason is ignoring my spaces):

…- It is a long established fact that a reader will be distracted by the readable
content of a page when looking at its layout. The point of using Lorem Ipsum is
that it has a more-or-less normal distribution of letters, as opposed…

…- It is a long established fact that a reader will be distracted by the readable
content of a page when looking at its layout…

Does anyone know about this problem?

…Actually, having a closer look, it has ignored all my indentations where I intended my paragraph with a few cm…! :frowning:


It’s happening because in Compile, you’re overriding the formatting, so the indents are being replaced with a first-line indent as set in compile’s Formatting pane. Depending on your goals, you can fix this a few ways.

The best way is to select your lists (and other special formatted text) in the editor and choose Format>Formatting>Preserve Formatting. Then in the Formatting pane of compile, you can leave the override selected but click the “Options…” button to choose how the Preserve Formatting should work: in your case, you’ll probably just want to “preserve tabs and indents”. This lets you still use the compile options to standardize your formatting across all the documents you’re compiling, producing a clean, readable manuscript. And it gives you the flexibility to change the formatting preferences later to output to different specs.

The other option is just to deselect “override formatting” in Compile, so your documents will all be compiled looking basically the way they do in the editor–this means your indents will stick, but it also means if you used different fonts or spacing or font sizes, etc. throughout your project, you won’t have a uniform manuscript at the end.

Hi MimeticMouton,

Thanks for the reply! I’ve been experimenting with what you suggested this past weekend, but I am still frustrated with a few elements…

I tried using the Preserve Formatting and marking one of my lists. When compiling, I checked the option to “Override text and notes formatting”, clicked Options and under the section “Preserve Style only preserves” checked Alignment and Tabs & indents.

The result is that my bullets now appear on the first line followed by an empty line and then my bulletpoint text at the same indentation as the bullet… In addition to this, the indentation of the bullet moved approximately 1cm to the right (even though I used preserve formatting)! When skimming through my document, there is one bullet list (containing only one item) that is properly formatted…Thoroughly annoying.

I then tried to avoid using “Override text and notes formatting” since I keep my document tidy from the get-go. I also use a fair bit of indentation for my paragraphs so marking everything with “Preserve Formatting” is very impractical. This option has yielded the best results (as far as the indentation of my other paragraphs), but the bullets still have any empty line between them and the text has the same indentation.

It seems that Scrivener is not very good at handling bullets which is causing me many headaches at the moment (and forcing me to use M$ products to clean up the mess…) :frowning:

Any ideas on what I might be doing wrong?

Scrivener is fine at handling bullets - it uses the OS X text system so handles them as well as TextEdit and any other program using OS X’s text system - so there must be a setting issue here, or an issue with the target program. What program are you opening the file in? And what file format are you using for the export? I’ve just tried exporting to RTF format (the best format to use in general) and opening in Word and bullets all look absolutely fine. How they look though will depend on the program in which you open the file, too, as many programs handle bullets differently. (Also, OS X’s .docx export is buggy when it comes to bullets and indents, so if you are using that, that may be the problem.)

All the best,

Once again Keith, thank you for the prompt response!

I’m getting closer to the solution now! After (ironically) disabling “use Word-compatible indents for bullets and numbered lists” I’m getting the correct results in MAC texteditor and Pages.

One other question (hope it’s okay to ask here instead of a new thread - should be short):

My footnotes are not appearing in the exported rtf - is this due to the rtf capabilities of MAC texteditor and Pages? When I use “Flatten footnotes and comments into regular text”, I see the footnotes but as endnotes… How do I get them on the same page?

PS: the warning “Note that for this format, footnotes will become endnotes when compiled” in the Footnotes/Comments screen took me a while to figure out that it was due to the checkbox for “Flatten footnotes and comments into regular text” in the Layout Options… A tooltip here would have been nice and saved me some confusion (I initially thought it was referring to the filetype so I was trying with docx, PDF etc.) :slight_smile:

Ah, right, this makes sense. The reason for that setting is that many text editors seem to handle bullets differently. The RTF specifications are very vague about how they should be handled, and different editors handle them in different ways. That is to say, there is a standard way of encoding bullets in RTF, but there are no set guidelines on whether, upon reading the RTF, the editor should place the bullet before the first tab or after it, or start the text after a tab or after an indent and suchlike. I added that option because it seems that the Mac text system handles it differently to Word, but other word processors handle it the same as Word (and others handle things differently still!).

So, unless you are targeting Word then it is probably a good idea to untick that, as you have done.

Not a problem - we aren’t strict on off-topicking in these parts!

Your assumption is correct - the OS X text system in general knows nothing of footnotes (or comments, or headers and footers) and so they get stripped. I’ve had to add code for all of that myself. Unfortunately, even Pages doesn’t have good RTF support - Apple have extended the .doc and .docx translators in Pages to support all of these things (but the standard OS X text system still does not support such things, and unfortunately I haven’t the resources to extend the .doc and .docx exporters in the same way I have the RTF exporter simply because they are such massive formats - I’d need a whole team working solely on that). So, footnotes won’t appear properly in Pages or TextEdit.

The workaround is to export as RTF and open the RTF file in Word or OpenOffice (the latter being free if you don’t have Word to hand) and save as .doc from there, then open that file in Pages. You’ll never see footnotes in TextEdit, though, no matter what format you use.

Or, you could use Nisus (my preferred word processor) or Mellel, both of which have excellent RTF support. And if you have a moment, please leave feedback for Apple asking them to extend their RTF support in Pages to include footnotes, headers and footers, comments and images:


I am told they do take into consideration how many requests they get, so maybe if enough people ask them we will get better support. RTF is a standard format dating back 20 years, and is second only to .doc/.docx in its ubiquity in the Windows world, so it’s a shame it’s not better supported in Pages, especially when .doc and .docx are such beasts for third-parties to support, and when Apple doesn’t make the .pages format available to anyone outside of Apple.

I can’t reproduce this - when I tick that option and export to RTF I don’t get the warning. The option is only available for RTF, because that’s the only option that supports end-of-page true footnotes. For other formats (.docx etc) you will get that warning because it is a limitation of the export.

Hope that helps.

All the best,

Wow - do you ever sleep Keith? :slight_smile: Clear answers and oodles and oodles of information which is well appreciated!

I will definately leave a comment with Apple for better RTF support!

The warning by the way was not a popup or anything, but a small sentence appearing in the Footnotes/Comments screen (just underneath the Footnotes format drop-down) when the option for “Flatten footnotes and comments into regular text” in the Layout Options is checked…

The warning shows on the Footnotes/Comments pane when compiling to RTF if you first tick “flatten footnotes and comments into regular text” in the Layout Options of Compile–it’s just the same note that appears if you compile to PDF, etc., displayed under the Footnote Format drop-down menu.

…Which is to say, sometimes this message does refer to the file format you’re compiling to (e.g. PDF, which doesn’t support end-of-page footnotes), which is why it sounds like that. :wink:

EDIT: Whoops, repeat.

Glad it helped!

Ah, got you. That’s because when you click “Flatten footnotes” it basically switches out the whole “Footnotes” pane for the one that is normally used by PDF, .docx and suchlike.

All the best,