Bullets compile fine in Word and rtf, and in Epub, but in Kindle/mobi the second and subsequent lines are too far to the left.

Is there some way to fix that please?


Does anyone else have this problem?

Hi, Peter,

Yes, I am experiencing this same problem trying to compile my latest book. I use bullets extensively throughout the book and this is making me crazy! I’ve not found a solution for it yet, except to compile to .docx Word format first, then the bullets look normal… but it does other funky things to the manuscript such as randomly removing spaces between words! :imp:

If any of you Scrivener user pros out there could offer any suggestion… I’d be your bestie!! :mrgreen:


How do you format the mobi? Compile directly from Scrivener? Have you tried letting KDP create the mobi from an epub compiled by Scrivener?

I’ve tried creating the MOBI directly with Scrivener compile, and also by compiling to ePub.

The best result I’ve had so far – and it is still FAR from perfect – is compiling to Word’s .docx format, then using Calibre to convert the Word doc to ePub.

Not a great workaround - but unless something can be done about the bullet formatting issue, there may be no other option.

Biggest challenge doing it with the Word workaround is it is doing some funky spacing thing seemingly at random. :frowning:

Yeah, that’s good old Word. :frowning: :frowning:

hah, no doubt! Scrivener has always worked great for my fiction - but of course those don’t require much in the way of formatting… but this is seriously driving me to drink, I think. I might have to go buy bigger wine glasses! :laughing:

So I went back through on Scrivener, those randomly removed spaces are correct in my Scrivener manuscript - so no clue why they are deleted in the compile to docx.

I recompiled, marking each page with Compile As-Is, which seemed to help the font formatting issues - kinda. It looked great until about 1/3 of the way through the book, then it reverted back for about 50 pages, then it went back to the correct font up until the last chapter where it went back to the incorrect font. :open_mouth: … but in Scrivener it looks perfect…

I’m just kinda’ shaking my head over here :unamused:

Ok… now let me put in a disclaimer here (LOL)… I don’t recommend the following “fix” unless you are familiar with HTML / CSS, etc.

Here is how I fixed the formatting issues:

Compiled my manuscript to ePub from Scrivener

Added the ePub to Calibre

Opened ePub in Calibre
sure enough all the bullet / font formatting problems were there

Edited the ePub from within Calibre
This will open an editor through Calibre that will show you the XHTML files for the ePub. You can work through the code of each body file to find the problem areas - then edit the corresponding class in the CSS stylesheet file to fix.

Again… I do NOT recommend this for anyone who isn’t familiar with HTML/CSS (I’ve been in IT/Web development for a looooong time lol)

But… this fixed it for me… figure I would share! :slight_smile:

I have worked out how to fix this.

This solution appears nowhere else on the internet!

I discovered that my bullet paragraphs had first line indent in the editor before I bulleted them. So I unbulleted them and adjusted the bullet paras so they had no first line indent. I then rebulleted them and recompiled. That fixed the bullet incorrect indent problem when compiling to mobi (and I guess other formats - I haven’t tried).

This is kind of counter-intuitive as changes in the editor are not supposed to affect the compile (unless compiled “as is”, which this was not).

So not sure why it works but it does work.


I have the same problem - but can’t get this solution to work for me. How should I be setting the first line indent? I have tried using the ruler and setting the first line indent to zero - but that seems to have no impact on the generation of second-level bullet points in the kindle edition.

Any ideas or suggestions gratefully received!

Hi Dr Rob

Sorry this is not working for you.

Yes I am using the ruler.

Make sure you unbullet and then set the frst line to no indent with the ruler before you bullet it again. Once you bullet it the first line indent jumps to indent again, but for me anyway it is the state of the first line indent marker in the ruler before you bullet that seems to make the difference.

Also in my compile settings I have everything set to no indent. I don’t know whether that is a factor but that is what I have. Again using the ruler in the Compile/Formatting section.

Hope some of that helps.

To the Literature and Latte gang: Do you have an answer to this important question? (Which drove me mad and cost me hours before I “solved” it.)



Thank you for your fast and clearly explained response. Sadly it didn’t work for me - so I am now working around this by using sub-headings and only one level of bullets.

Others / Admins,

I don’t know how to raise ‘bug fix’ requests for Scrivener - but I have attached two images of this defect in action. I am happy to forward example source files if somebody wants to look at this.