Can not compile entire document

Just updated to and my word count went down. Tried to compile and it cut off he last 5 chapters of the document. Not very versed with this program. Is this a problem and is there a fix?

If compiling to PDF, compile to Word first, then save as PDF.

Else, check the Filter icon in the Compile Overview window. If it’s blue, remove any filters.

Make sure the Manuscript/Draft folder is selected above the right column in the Compile Overview window.

Why compile to Word first, then PDF? I’ve not found any disparity compiling directly to PDF.

1 Like

Because there’s a bug in Scrivener, causing the last pages of a PDF not to compile. :wink:

Are your last 5 chapters ticked for ‘Include in compile’?

Another consideration is: Are they in the Manuscript/Draft folder?

1 Like

I’m on Windows too, version Did a quick compile of my WIP to PDF - 138 pages. The last page is there.

1 Like

PDF or Word doesn’t make a difference. Not sure about Filter Icon. right folder.
Additionally the chapters at the end are not showing up in the compile overview window.
Trouble began after update. Thanks for your help.

These last chapters are not on the list in the compile overview window. Thanks for your help

@willstevenson - I don’t think you’ve answered @Kevitec57’s questions above. Please do so. They are fundamental to solving your problem.


If the last chapters are not listed in the overview, then they won’t be included in the output document. At that level, Scrivener is behaving as expected.

So the question is why aren’t they listed? The most likely reasons are that you’re using a Filter that excludes them; that you’re compiling a subset of the project that doesn’t include them; or that they aren’t in the Manuscript folder. I would guess one of the first two, since presumably you’d know if you rearranged the project.

I selected the last few chapters and moved them right under the edit button. This solved the problem. I don’t know why it worked. But thanks for all the feedback.

If that worked, probably the missing documents were not inside the Manuscript folder, then they were after you moved them right.