can`t download other dictionary[ADDITIONAL INFO]

when I try to download the german dictionary - the dictionary downloader shows progress until 100 % and following message:

After restart Scrivener, there are still just the three engl. dictionaries to choose from, no german one.

Scrivener v Beta 1.6
OS Windows Vista

I have the same problem with the french dictionary. When I start downloading it I have the same kind of errors, with at the start the message:

Preparing to download: fr_FR.multi, fr_FR-80.multi, fr_FR-60.multi, fr_FR-40.multi, fr_CH.multi, fr_CH-only.rws, fr_CH-80.multi, fr_CH-60.multi, fr_CH-40.multi, fr.multi, fr-80.multi, fr-80-only.rws, fr-60.multi, fr-60-only.rws, fr-40.multi, fr-40-only.rws…
Could not open fr_FR-60.multi for writing: Accès refusé.
Could not open fr_FR.multi for writing: Accès refusé.
Could not open fr_FR-80.multi for writing: Accès refusé.
[… and so on]

Then the download continue and it indicates “Download session complete.” so I click on close, but the dictionary isn’t showed in the choice panel, neither immediately neither after restart of scrivener.

I use windows 7.

This is a Windows permissions issue that is preventing Scrivener from saving the files to the Scrivener/Aspell/dict directory.

Right click on the ‘dict’ directory folder in Windows explorer, select properties, then security tab as shown in screen shot below. Ensure that LOCAL has full control, if LOCAL is not in the list simply add it and assign full control. Then try the dictionary download again as Scrivener should now be able to write downloaded files to this folder.



It’s been confirmed that there were several users who had permission issues installing Beta 1.6. I did make several changes in the installer around permissions to enable the live-update code for when we finally drop it in and prevent all this installation madness.

I was just thinking that if someone wants to download the updated 1.6 beta installer and see if the learning words issue still persists? … taller.exe

If it does then we can rule out permissions as well. If it fixes it, then a simple re-installer is all that will be required - wishful thinking on my part.

Let me know how you go.


… yes, new updated 1.6 beta installer works splendid. I could download dictionary file without problem. After restarting scrivener the new dictionary turn up in the list.

This problem is solved.


It work perfectly with the new installer for th dictionnary install.
For the learning words problem I tried with the right click -> learn word, and with the options window by adding a word to the list. For both, the word is still underlined in red, but if I restart scrivener it’s ok, and the words are no more underlined. So I suppose it’s solved, it just need a restart.

edit: So when I restart scrivener, words learned are normal, but, if I add a new learned word, all the learned words from the list become underlined in red. It come back to normal with a restart, last learned word included.

Hi guys,

Seems that with the latest version ( of Scivener for Windows, the dictionary problem has returned. I tried to download the French Dictionary, got exactly the same symptoms (a bunch of “Could not open …” ) and it ended with a “Dictionary download failed”.

I tried to access the dictionary folder as Lee said, saw that the LOCAL user already has full control. I tried to restart Scrivener, to no avail. I even tried to download another dictionary, in case the French one was somehow broken, and got the qame results.

What should I do ?

Back from the graveyard for this topic, because we are now at version and it’s STILL not working. I understand it’s by far not a major bug, but still, mods, could we have a word about that issue ? Even if it’s a “cannot work on it right now, it’ll be fixed for version 2.0 or later”. Just so we know the problem has been noted and will eventually be addressed… please ?

@Alake: Unfortunately, we could not reproduce this bug in our tests with, Alake. Can you try running Scrivener with elevated rights as Administrator and try downloading some dictionaries again. If you installed Scrivener as an Administrator and run it as a normal user, it might also cause a problem.

Changed my version to, ran it as admin, and the installation of the French dictionary was flawless. I then closed Scrivener and tried to run it as a normal user, and it worked.

Thank you !

Glad it worked! :slight_smile: Enjoy!