Cannot compile to doc

After the update I have been unable to compile to doc. I can compile to mobi, epub, docx, and odt just fine.

Trying to convert to .doc gives the following error:

Could not convert to specified format.

Format Converter Not Found.
Converter Error: SubSystems cannot convert RTF to…


I would try one of the other converters. You can experiment with them in the Import/Export options tab. Worst case though you can often just use RTF (and if you have someone complaining that it isn’t a real Word file, just change the extension to .doc and hardly anyone will be wiser :slight_smile:). That’s going to be better than conversion, or if you really do need an old style binary .doc (mobile suites often don’t support much else) then use Word or OpenOffice to make the conversion. Hopefully you can find a working solution in Scrivener for the convenience of it, however.

I can’t compile to doc or docx since the last update.
I get two responses, one it tries to do so and the nothing happens. The other is that it keeps trying to compile and I have to abort to move forward.
I’m using windows 8.1 and in order to try something new, I have to reboot the computer after the compile has failed, or I get an error that shows ‘save as’ failing.

I’ll reboot and try the RTF, and post a new response.


Compile to RTF worked, but with very funky formatting.

When I opened the file, the failed compiles were in a recovery box. They were the ones that kept running. When I aborted and shut down, there were some save dialog boxes so I hit ok to get out.

So, I guess I need to go hunt down the setting that says where to compile docs.

I’m sure L&L will find a fix

Are either of you running antivirus software? If so, please check that and see whether it has quarantined any files from Scrivener, or if it is active during compile. We’ve had a couple reports over the years where software such as BitDefender has flagged the Doc2Any converter that compile uses and thus prevented successful compile, so you may be running into something similar and need to whitelist that and possibly reinstall Scrivener (if the files were moved from their original installation location). The converter is safe to use, but as it does call on other libraries–for instance, it will access the Microsoft Office libraries for better conversion to Word formats–it can sometimes set off an overzealous security program.

SubSystems is another third-party converter that Scrivener uses which could also be getting flagged, though I haven’t seen reports on that otherwise. We did just upgrade to a newer version for better DOCX export and import, so it could be a new problem.

I am having the same error, I never saw it until this new update downloaded last week. Whenever I try to compile my documents into a DOC format it refuses saying RTF cannot be converted to DOC.

This is a rather important problem considering that Word is the major word processor and most publishers and agents want documents in that format!

It would really be helpful in tracking down the problem if you could try different converter options and let us know which one isn’t working, also which version of Word you are using. Also whether this problem is specific to a certain project–try creating a new blank project, entering some text, and then compiling that. If you’re getting specific error messages, a screenshot of that would help, too.

The problem is that this isn’t an issue for everyone, so it’s not simply that the converter isn’t working, and it’s therefore not simple to just look at the code and correct a broken line somewhere. There are a lot of factors that go into the conversion process, and inevitably the conversion tool will not work for everything–there may be some formatting that just doesn’t take, or the process may just demand too much memory for so large a file that a given computer at a given time doesn’t have the available resources to handle it. If we can at least start collecting information or sample projects that are posing problems, we may be able to find a common factor that is triggering an error.

The only definite Word-related converter issue we’re aware of is that installations of Office 365 can cause the “Microsoft Word” converter options to be available, but the converters do not work with this version of Office since it is software as a service and uses a different API. The MS Office converters only apply to Office 2007 through 2013. We are working to address this for the next update, so that the Office converters do not show for Office 365 installations. If you are on Office 365, please choose a different converter option in the Import/Export options.

I do not even own Microsoft Word, but my agent and publishers want all documents sent in Doc word format. I use Scrivener and OpenOffice for documents.

Here is exactly what is says, I tried with a one page document and got the same error.

Could not convert to required format.
Format Converter not found.
Converter Error: SubSystems cannot convert RTF to //(my file name)

If necessary I can just delete the update and go back to the earlier version of Scrivener I guess.

Have you tried uninstalling and reinstalling? I’d do that first, because the error just sounds like there was a problem with the installation such that the converter libraries it’s looking for can’t be found. Please also see my post up thread regarding antivirus software–I’m aware of a couple cases where BitDefender has flagged one of Scrivener’s third-party converters as a potential thread and prevented it installing correctly, thus naturally messing up the compile conversion. It’s not always made obvious when security software does this, though, so go take a look specifically to ensure that it’s not quarantining files or otherwise preventing them from running. The converters are safe to use, but since they’re accessing various libraries they can set off some hypervigilant software.

You can save your preferences via the Manage menu button in Tools > Options, then reload them after the fresh install.

You should also have the option to convert to DOC as “RTF-based”, which will produce essentially an RTF file in a .doc wrapper to open easily in Microsoft Word. This would’ve been what you were using previously, since it was the only option available if MS Word was not installed.

I just now completely uninstalled scrivener and then reloaded and reinstalled. Same exact error as before.

It does save using the RTF for doc.

I do not have Bitdefender, never heard of it.

I don’t use word at all, do not own it. I don’t open these documents. Agents and publishers want my files in doc. I could try asking them if they can deal with rtf docs, but this is a rather significant problem and I don’t know how long I will want to use scrivener if I cannot produce doc files.

“RTF-based” DOC compile is the same as what you would have been using previously in 1.6.1; these files will open fine in Microsoft Word.

Could you provide a sample project that demonstrates the problem, either as an attachment here or to AT literatureandlatte DOT com referencing this thread? If the converter bug is stemming from some particular compile settings or formatting, that would be the fastest way for us to find and try to fix the problem, since we haven’t been able to reproduce it.

Also, just to be sure I’m clear, you’re seeing this specific message about “SubSystems” when compiling to DOC (not DOCX) using the Doc2Any converter?

I tried to attach a sample chapter that is failing to go to DOC, but it says in red “The extension rtf is not allowed”. So what kind of file can I attach that would be useful and is allowed?

Yes I am still getting that subsystem error for doc compile attempts. I have not tried DOCX.

I don’t know what the Doc2Any converter is, if I have it or what. Just hitting compile in Scrivener…

I just tried attaching my project file but got 2 errors, the extension scrivx is not allowed, and denied as possible attack vector…

I’d actually need the whole project in order to test it, although it can be a sample project and not your entire file provided that compiling the sample project is giving you the same error. You can either use Save As on your current project to create an example project and then strip stuff out of it or create a new blank project and then drag and drop from your main project’s binder to the new project’s binder to copy over some text for the compile test. Then use File > Back Up > Back Up To… and check the option to create a ZIP file and attach that here; I believe zipped files are allowed as attachments. Then you can delete the project from your machien to avoid confusion with your real one.

To check the converters, go to Tools > Options and click on Import/Export in the sidebar. Then click “Export converters…” and you’ll see a drop-down for file formats on the left and the available converters for each on the right. You should have both “RTF-Based” and “Doc2Any” as options for the DOC format. My understanding is that “RTF-Based” is working for you but “Doc2Any” is not and is producing the error you typed above, but I would really appreciate confirmation of that, since there are a couple different cases going on in this thread. DOC and DOCX also use different converters, so it was important to know whether you were compiling to DOC or DOCX. Thanks!

OK I found that the trial scrivener project I made when I first bought this in January also gave me that error when I compiled it. But when I saved it as zip and tried to attach it says maximum size allowed is 1 mb, it was 1.7 mb.

So I started a new project and just wrote one sentence. Then saved it as trial project. But it actually worked when I sent to doc. So it must be something in my earlier projects and not something I can reproduce with a new project.

My project is quite large, a large book, but I have only been trying to compile 6 chapters, about 50,000 words probably. I will try to figure out how to cut a piece out and send it.

Wow now I am baffled but ok with that.

I did some dinking around trying to cut and paste pieces into a new project, and did not get any errors trying to compile them as docs. At one point I accidentally moved the whole original project into trash and had to return it to Manuscript. Then I tried compile again on original, and now doc compile is working. I got all the chapters to doc with no errors.

Maybe fiddling with new projects somehow fixed something in the profile, or the trash error and return did something. I really have no idea what changed, or why it is working now. But glad all the same. I guess if it happens again I will contact you, but ok for now.


For what it’s worth I’m running into the same issue. I downgraded to an older version and it’s working fine now.

Are there any tables or images in the text documents being compiled? Working with another user who was able to provide a sample project, we did find a bug where using “Override text and notes formatting” in compile was choking on a complex table that had been imported from Word and when part of a larger compile it could end up freezing entirely. I don’t know of a similar case with pictures, and since they’re not text being formatted they’re probably in the clear, but worth checking all the same.

If you have any documents with tables, try setting them to “Compile as-is” and then running compile to see if that fixes the problem. (Of course the document will then not take on the compile formatting, but it will at least pinpoint the issue.)

Also, Heliocentric, going by your other post, could you please double-check the Formatting pane to ensure that the “Text” column is selected for all the rows? It sounds as though the problem you’re seeing with the formatting in compile is related to documents not compiling all the text you expect, which could be just a matter of changes in the compile dialog.

I would like to chime in on this problem. I am running both Office 365 and BitDefender. I excluded the Doc2Any process from BitDefender’s scrutiny, reinstalled Scrivener, and attempted to compile with the following file formats:

.rtf - empty file
.txt - looked fine, but it’s hardly want I want for my manuscript
.doc and .docx - Both attempts acted the same way: a File Save window opened with a long file name, not of my choosing, and went into a loop, saying that it was compiling with a status bar that reached 100% and then started over at 0%. When I clicked Save, the process stopped, a file appeared in the target folder with the name of my choosing, and it turned out to be an empty file.
.odt - empty file
.html - looked fine
.xhtml - looked fine

I performed this test after I ran into problems with my current work in progress, so I created a new project for a fiction manuscript with one “scene” of 100 words only. I updated to this version a couple of days ago; these problems with Office365 did not exist in the previous version. I will be reverting to the previous version, if possible.

Very disappointing. Let me know if there is any way to help with finding a solution to this problem.

Kathrese McKee

Kathrese - I’m sorry to hear you’re having problems. First off, I’d go into Tools > Options… and in the Import/Export tab, click “Export Converters…” You’ll see then two drop-down menus, a file-format set on the left and then the converter options on the right. You’ll want to switch DOC and DOCX to something other than “Microsoft Office”, as MS Office 365 does not work with the converters, but as noted earlier in this thread, it’s not distinguishing between Office 365 and Office 2013, so Scrivener is defaulting to those converters and giving you that failed process during compile. For DOC, I’d choose “RTF-Based”; this is what you’d have been using previously in 1.6.1.

Now, for RTF in general failing, that sounds like something specific to the project. I’m not entirely clear what you meant about creating a new project with one scene of 100 words–did you run the same tests with that and hit the same trouble for RTF compile? If so, did you copy and paste the text of the document from another project or other source, or type it fresh in Scrivener? More details about this would help a lot to track down the trouble, since it’s almost certainly to do with a combination of the formatting and compile settings.

We are aware of a bug, and have fixed it for an upcoming release, where tables copied from Word (and possibly other sources) can contain hidden formatting that will stall and sometimes completely freeze the compile process when “Override text and notes formatting” is enabled in compile. For PDF compile via “Scrivener”, it also can result in compiled documents with additional blank pages and empty tables.

Until the update is available, you can get around that problem by marking any documents containing copied tables to compile “as-is”, or by deselecting “Override text and notes formatting” in the Formatting tab of compile.

If you don’t have any tables in your project, we’ll have to look for something else. It would help a lot if you could provide a sample project that demonstrates the error when compiling. You can use File > Back Up > Back Up To… from within Scrivener to create a zipped copy of it to either attach here or mail to AT literatureandlatte DOT com, with a reference to this forum thread.