Cannot Compile to Word Document -- Scrivener Hangs Up

Hi there,

I’m running macOS Mojave 10.14.5 on a MacBook Pro (early 2015) with 16 GB of RAM. I’m also using Scrivener 3.1.2 for my thesis manuscript. I’ve been able to compile chapters separately into Word, but today tried to compile the entire manuscript without success. After I click the compile button, the blue progress bar ‘completes’ in less than 30 seconds and then a message beside the progress bar says ‘Formatting file types…’ (or something like that). It stays like this for at least 15 minutes, when I give up. None of my individual chapters needed more than a minute or two to compile. Once I hit the 15 minute mark, I’ve had to Force Quit Scrivener and attempt it all over again.

As a note, the last time I tried I restarted my laptop to clear the RAM, closed all apps, and even turned off wifi. Still didn’t work. Please help!


Have you tried using the new converter described in the thread linked below?

Slàinte mhòr.

Thanks for the idea JORO, unfortunately, it didn’t work–sort of. Unchecking the box in the instructions, in order to use a different converter, did compile the entire manuscript into Word very quickly. BUT, the formatting of the resulting Word document was beyond horrible. Tables and lists were completely messed up and the majority of my images were not included.

Update on Original Post:

My manuscript has 7 chapters. I am able to compile each chapter separately, without any issues. I am also able to compile chapters 1 to 4 and 6 and 7 together, without any issues. And, I can compile the entire manuscript MINUS one section in chapter 5, without any issues. When I add this one specific section in chapter 5 to the compile, it hangs up. BUT, I can compile that chapter and section on their own!

I’m not a Scrivener expert, but this doesn’t make sense! There’s obviously an issue with this one section, but I would have thought it wouldn’t compile under ANY circumstance, but that’s not the case. It only has an issue when I add every other part of the manuscript to the compile.

Any help would be greatly appreciated.


Did all of your text originate in Scrivener, or has some of it been pasted in from elsewhere?

You could try duplicating your project (so you have a backup), loading your entire manuscript in scrivenings, putting the cursor in the editor, and then choosing Edit > Text Tidying > Zap Gremlins. This command should clear any odd ASCII characters that might be causing problems. Then try running compile again with the different converters to see if either works correctly.

Are you trying both .doc and .docx? What about RTF, does that compile cleanly?

Slàinte mhòr.

Hi Again,

All my text originated in Scrivener, but the images were copied and pasted in. The section in chapter 5 that won’t compile with the rest of the manuscript has images, but it’s not the only section that does. I did try compiling in RTF and had the exact same issues.

I created a new copy of my project and zapped the Gremlins, then tried to compile again. It’s been at it for at least 20 minutes. So…I don’t think Gremlins were the issue. :frowning:

Thanks again! If you have any other ideas, let me know!


As another diagnostic test, if you duplicate the project (for a backup) and remove the images from chapter 5, does it compile? If no, it’s not the images. If yes, add one image back in at a time until the issue recurs.

Anything unusual about about the images or anything else in that chapter?

Slàinte mhòr.

Hi JoRo,

Thanks for the diagnostic idea! I’ll try that tomorrow when I have more time.

Almost all the images in my manuscript are screenshots (taken a variety of different ways). Some of them have been edited in Evernote (to anonymize). From that perspective, there’s nothing special about the images in this one section. But maybe one of them is corrupt?

I still don’t understand why the whole chapter and that one section can compile on their own without issues. From a technical perspective, what is happening within that one section to cause it not to want to compile with larger portions of the manuscript?

I’ll let you know how it goes!


Hi, aliciavc.

All rather perplexing as the alternative converter worked to compile the whole file (but messed up the formatting) and chapter five will, as you say, compile in isolation…both suggesting that there is nothing significantly awry with the file, although sufficient enough to cause a failure in some circumstances.

Images can be problematic, so it would be useful to rule them out through test compiles. Is one image used twice: wondering if a duplicate image / image name is enough to send one version of the compiler into a spin.

Perhaps it would help to share the project with the tech-support team and let them debug it for you.

Other complete projects do compile to Word correctly? So this is a project-specific issue, not a universal one?

Hope your tests work or that someone else can offer a solution.

Slàinte mhòr.