"Cannot Export- Access Denied"

I have just found to my dismay that I cannot export binder files to rtf.

Instead I get the message:

I have tried saving to many different locations, but always get the same message. I am using Scrivener for Windows and when checking, I’m told that this is up to date.

Searching the forum, I find that in 2012 this was considered a “known issue.” Has there been any resolution, or can someone suggest a workaround?

Are you selecting a folder or document that does not contain any text? I believe this issue just occurs when an empty file is selected, so you should be able to work around it by adding text to the item or selecting individual components if that’s not possible (e.g. if you’re trying to export the entire Draft folder). The good news is that this has been fixed for the next update.

Thanks for the reply, but this is a folder with a great deal of text.

Just to be sure I’m clear, I mean that the folder itself needs to have text, not just that it contains subdocuments; in Scrivener folders can also act as documents, with their own text, notes, etc. But assuming that’s the case, do you have any special characters in the folder title? Are any of the folder’s subdocuments blank? Is everything text or are you exporting different file types, e.g. some PDFs or JPGs? Try excluding those if so and see if that allows the others to export correctly.

Thanks for the clarification (and your patience!)

Your surmise was correct that there was no text in the actual folder-- instead, the folder contained several text documents.

Following your suggestion, I added a few lines of random text to the folder itself, selected it, and went through the export procedure. When I opened the resulting file, all that appeared was the random sample text-- nothing from the subdocuments.

Am I doing something wrong here?

Subdocuments should be exported automatically, using a standard file/folder hierarchical structure on your drive. If you have folder A with text, containing subdocuments B and C, when you select and export A to your Documents folder you should end up with a folder A in Documents, which contains files A, B, and C. The file A will only contain that folder’s text, but files B and C should contain the appropriate text for those binder documents. Are you not getting this folder structure when you export?

Note also that in 1.6.1, the “Save As” name you supply in the Export dialog is used for the top level folder, so in the example above if you changed this from the selected folder’s name “A” to “All My Stuff”, you’d see that “All My Stuff” folder in Documents and it would contain the files A, B, and C directly; there wouldn’t be an additional “A” folder. That could be causing some confusion here, depending what you’re looking for to find your exported files.

If all you’re getting is just the file for that one folder’s text, could you post a screenshot of the binder showing the folder and its subdocuments? That might give a clue as to what’s going wrong in the process and how to fix it.

Jennifer, thank you for this very detailed reply. I am beginning to think that I misunderstood the “save as file” function. I had been expecting that the text documents within the folder would all be combined into one file. However, on the last try, I did get several files corresponding to the documents in the folder. If that is the way it is supposed to work, then I guess everything is okay.

Thanks again.

Ah, yes, ok. The export function essentially makes an external copy of the selected documents (and subdocument), just as you see it in the editor, though with text documents you do have the option of exporting to another format like PDF or .doc (whereas natively within the project they are RTFs). To pull everything into a single file the way you’re describing, you want to use the Compile function. This offers many more options in how the text should be formatted, what should be included for the files (e.g. you could choose to include not only the document text but also their binder titles and a “Chapter” prefix), how each section should be separated, and much more.

For a basic compile, maintaining the original editor formatting for each document and just pulling them all into a single document separated by blank lines, choose to Format As “Original” and run the compile to get everything in your Draft folder. To play with more of the settings, click the blue arrow button to the right of the Format As drop-down menu. In the “Contents” tab that you’ll then see, you can select just the “Odanah Incident” document group from the drop-down menu so that the compile group is limited to just that file and its subdocuments rather than the entire Draft.

I suggest also taking a look at the chapter on Compile in the user manual (available from the Help menu) or looking at the section of the interactive tutorial that runs through a few compile examples to help get a feel for how it works.

A possible way to do what RangerBob wants without compiling might be to use the document merge function. In the binder, select the folder and all the documents in it. Then on the Documents menu, select Merge; or press Ctrl+M. This will combine them all into a single document under the title of the first document selected, i.e., the folder, and that document can then be exported. AFAIK, this can’t be undone, so be careful with selecting the documents! In fact, you’d probably want to create a duplicate of the project and do this on that duplicate, so that you could continue working with the individual documents in the folder in the original project.

Thanks both of you for all this very useful information.

I guess one of the things I will learn from this is not only should one read the manual-- which I did-- but read the chapters in order-- which I didn’t. :smiley:

Thanks again.

Given DavidR’s followup, I just want to add that the compile process, while giving you a lot of power to control various aspects of the output, doesn’t need to be complicated. Using the “Original” settings as I mentioned and choosing RTF in Compile For and then just selecting the specific group you want to compile from the drop-down menu in Contents is all you need to create a copy of the text like you were doing with File > Export, but as a single file. You can happily ignore all the other settings in Compile until you’re ready to experiment with them.

Sounds like an excellent idea. Thanks!