Cannot open any projects on MacOS

I hadn’t opened scrivener for a few months. Now I can open the execution file but none of my scrivener project files will open. I get a message that there was a problem saving the architecture and a recovery file will be saved. The file then shuts down automatically. The recovery files are all rtf’s so they would require rebuilding the entire project from scratch. I tried making a copy of the project and moving it to the desktop but it still triggered the same error messages. It’s happening with two separate projects. I’ll be sad to have to rebuild them from scratch!

I am using version 3.3.6 on MacSonoma 14.3.1 and I use dropbox to backup and sync all my work files. I tried to include screenshots of the error messages but the board would not let me.

Thank you!

By the way, I have found the .scrivx files, which are still in the same folder as the project. The permissions say that I have full read & write permissions for the .scriv & .scrivx files. I noticed that there is a quick message when I try to open the project that it is “indexing files” before I get the error message.

The updated Tutorial file does open properly.

Exactly where are the files? On a folder location that is synced with another server local or on the Internet?

Local, but on a folder that is synced with dropbox.

The most common cause of this error is that Dropbox is “helpfully” storing part of the project exclusively on their server, where Scrivener can’t get to it.

Edit: If that doesn’t help, please post a screenshot of the exact error message you’re seeing. I’ll up your trust level so you can.