Cannot open my project after updating (yes, panicking)

I updated from Scrivener version 1.51 to the newest version and now I cannot open my project. When I first tried to open it, I got a message saying I needed to update the file and I clicked to accept that. Then I just got a message saying the file couldn’t be opened. Then when I try to open the original file again or the “backup” file that was automatically created, I got a scary message saying that no .scrivx document can be found. I contacted Scrivener but haven’t heard back. Then looking around these forums I saw something about needing to first update to Scrivener 2 and then to Scrivener 3, so I downloaded Scrivener 2.5, but I get the same long error message (no .scrivx document found) trying to open it there. Obviously I am freaking out and I wish I had never updated. (Though I am trying to convince myself that my manuscript has not been deleted, must still exist, and it is just a matter of figuring out the correct way of opening it). I emailed Scrivener support again but just get a message saying to expect delays in response.
Has anyone here had this problem and have any suggestions how to fix it? Many thanks.

You need a later version of Scrivener 2, like 2.8 or 2.9

Yeah, I’d go with the 2.9 version rather than the ancient 2.5 version. Only reason to use that is if you have a computer that is far too old to use 3.0 anyway (as in PowerPC old).

Well the backup would be in 1.x format, which will never have a .scrivx file in the first place. So it sounds to me like you tried to open the backup in the new version as well, which is only going to duplicate the original test precisely and produce the same result (and it’s worth keeping in mind you likely now have three backups, one that is the original).

I’m sure the original is fine, but if you want to reassure yourself of that, download 1.51 and open the backup with that. That’s the only program that knows how to actually open the backup and look at it directly. Everything else is going to try and create a new version out of the raw data. If that process won’t work, they are thus imperfect lenses by which to judge the integrity of your project.

Meanwhile, if you haven’t already, send us a copy to the support address in response to the auto-responder email you got. We can much more quickly identify the problem and maybe even get you the updated version in response.

Thank you!
I have emailed support twice but am still waiting to hear back. I will try downloading version 2.9 instead and see if that helps.

Okay, I found your support ticket in the system. It looks like you wrote in over the weekend, that’s why there is a bit of a delay. I’ve just sent a response to you there.