Cannot transfer work to new computer

I looked at a similar post from a while back and the advice was to go to the folder projectx.scriv and open it; then to open the file project.scrivx. I don’t know if that worked for the person because the posts stopped so I followed that procedure.

I bought a new computer and have my backup files from the old netbook on a flash drive because the netbook would not install dropbox. I put the flash drive into the new computer and double-clicked on the nameofmyproject.scriv on my flash drive which had my latest backup date. I saw the following folders: files, settings, and project.scrvx. Also saw three files called files, settings, snapshots. Double-clicked project.scrvx and was greeted with the error message:

Cannot access: 'C:/blah /blah /blah /blah/project.scrivx. File is not writable: Access is denied. Auto-saves need write permission to you your project.

Is there anyone who can walk me through this in a clear, concise way, please? Thanks.

The error message means that the file is currently set to read-only, e.g. if you had a zipped copy of the project and double-clicked the zip folder, Windows would show you the file contents, but you would not be able to edit them at all. Scrivener needs to be able to save changes to all the files in the project as soon as it opens, in order to keep everything in sync, so if the project isn’t writeable, Scrivener does not open it at all.

In your case, if the project isn’t zipped (you’d see a zippered folder icon for it, even if you don’t see the .zip file extension), it may be that your new computer’s account doesn’t have permissions to save changes to the flash drive. You can right-click a folder or drive to check its properties and permission settings to make sure your account name is listed with write access.

see next message, thanks

I have had this tablet a week - it’s a microsoft surface pro which I bought because I could use Scrivener on it. Downloaded Scrivener to it, opened my last project, no problem. I have been working on it just fine until today when I lost some text and wanted to look up an old draft to get it back. Guess what? I now get the same message as the above when I try to open any saved scrivener project.

I tried right clicking and checking the properties, and it that I have full read and write access on this computer on those projects, with the name of this computer there etc. I checked from folder to individual files, and all are clear.

Thanks for helping. I’ll start saving another way until I get this cleared up. (no icon for a sob)

How have you been sharing the project between computers? SkyDrive has been giving some users problems, and someone was just posting the other day about it apparently making some documents read-only unexpectedly.

When you say you’re getting the “File is not writable” error for saved projects, is this true for new projects you’re creating on the Surface, or just for ones you’ve copied from the other machine? What about the one you had been working in just prior to opening an older copy and getting the message? I’m not entirely clear where the projects or stored or how they’re stored, so it’s difficult to say what’s causing the error. If you could provide some additional details on the file set up you have, that would help us figure out what’s going wrong.

HI - they are stored in dropbox and those are the ones that are giving the “read only” message - however, the properties all say they are both in read and write. They were all saved while working from another computer.

The ones stored on my hard drive and secondary backup drive open fine. I realized this and retrieved what I needed. Still would like to be able to access via dropbox.

Here is a link to what I see when I try to open it…can you open this? … .58.15.png

Thanks for the screenshot; that shows the problem clearly. You’re trying to access the projects within the zipped backup folders without first extracting them. Zipped files are read-only, and Scrivener needs to be able to save to the project folder from the moment you open it, as it’s saving not only the writing that you do but also the state of the interface and so on.

To extract your backups, either right-click the zipped folder and choose “Extract All” or double-click the folder and then drag out the .scriv folder to another location. You’ll then be able to open the project in Scrivener as normal.

Enclosed is a copy of another screenshot showing what I get when I right click on the file. … .44.47.png

There is no option to extract. When I click on it (either once or twice), I get the error message, as seen earlier.

When I drag it to my documents folder and click on it, Scrivener opens with the same old error message and a copy of the project with all the scenes/files but no words - in other words, none of the writing. See: … .48.49.png

I’ve already gone deep enough into the zip file to get to this and I believe it’s been extracted. But if not, whatever the case, I have used Scrivener on this computer in conjunction with dropbox in this way without a problem for months by simply clicking on the .scrivx file. It would open without a problem as a Scrivener Project on my computer up until about a month ago when all of this started. I cannot believe the time I have had to devote to this.

The only thing that has changed is that I upgraded to Win 8.1 from Win 8. I was ALWAYS clicking on the project.scrivx file before, and it would always open Just Fine. In other words, I am doing the same thing I always did and getting a different result, e.g. said error message.

I’ve GOT to be able to save my backups in a useable fashion, as I’m sure you understand.

Go one step up and right click on the zip file–that should give you an option to extract the scrivener project.

This has been an ongoing issue, and I would prefer working with the same person or someone who has dealt with this issue as I am sure it is not limited to me. Robert you have always been willing to be of assistance here and on the nano website, and even at our nano meetings here in St Louis, so I appreciate your trying. The thing you suggest has been tried.

One of the things that needs to be said is that not only, as mentioned, have I always been able to open the project.scrivx file in Dropbox until the issue began about a month ago (after downloading 8.1 to this computer which had Win 8 previously), project.scrivx STILL opens perfectly from my hard drive and the external hard drive I have connected to it. So I can still open most current copies of projects. Otherwise, the smilie faces that would be coming off of these emails would be causing volcanic ash to arise from these emails. However, it’s still important to be able to access projects that are backed up to a cloud drive. Why else have them backup there if one cannot access them? The problem is exclusive to the cloud drives, e.g. DropBox et als.

For the benefit of those who might not have reviewed the screen shots but may be searching on the same issue, the error message in DropBox is:

“File is not writeable. Access is denied.
Auto-saves need write permission to your project.”


mom42terrificgirls and TravelingBard,

I’ll offer the following in the hopes that it is more help than hurt. Robert or the Scrivener folks can correct me.

File compression consists of taking one or more files, quite often entire folder structures/contents (as an example a Scrivener project .scriv folder which may contain hundreds of files), compacting them size wise and lumping them all together in a single physical file, usually having .zip on the end of that file’s name. This proves useful for signficantly reducing storage space used and for assuring entire collections of files can be dealt with as single easy to copy/backup/transfer/manage items whose integrity can be assured.

The catch is that their contents generally cannot be directly edited or worked on. Such compressed .zip files generally need to first be extracted/decompressed, producing an extracted copy of the contents elsewhere that can then be directly edited or worked on, used for recovery, etc. In newer versions of Windows, one basically does this by right clicking on the .zip file and specifying extraction of the contents to some location. In older versions of Windows, or if one prefers, this may involve the installation and use of some third party compression utility… WinZip, 7Zip, etc.

Windows (and presumably Mac OS X) can tend to fake one out on this issue, as the file system explorers allow one to somewhat transparently drill into .zip files and view their contents, without realizing that one has crossed the boundary between regular file system and compressed file contents.

If, when one is viewing the contents of a .zip in this manner, one opens a single simple .txt or .rtf file, it appears that one can edit/change and attempt to save the file. Problem is, what one is editing is a temporary copy of the file that Windows has supplied… and when one goes to save, will have to specify some other location, outside the .zip file, to save it to. (There are some third party utilities that can sort of work around this on a file by file basis, but they aren’t practical for a simultaneous multiple file situation like databases or Scrivener projects.)

That’s what you are encountering.

Basically, think of a compressed .zip version of a Scrivener project folder being a frozen project. You can look at its contents (to some extent) in file explorer, but in order to actually work with it as a live project, you first have to thaw/unfreeze (i.e. uncompress/extract it).

In TravelingBard’s screenshot, note the presence of “” in the directory path being accessed. That is a compressed .zip file. Windows is trying to be helpful… letting you peer inside the .zip file at its contents… but is also misleading a bit, in that in doing so, it gives the impression that the contents should be directly editable by Scrivener. They are not. They have not been extracted.

In order to access those contents via Scrivener, they first have to be extracted back out into regular file system format. That can be done by right clicking on the .zip file and specifying extraction to some other location, where Scrivener will then be able to work with them.

A Scrivener project is a regular file system folder (with .scriv on the end of its name) that is created wherever you told Scrivener to create it or where you copied one or extracted a compressed version of one to.

Auto-save backups are compressed .zip versions of project folders, maintained wherever specified in Tools > Options > Backup > Backup location.

Additional on-demand backups created whenever one wishes via File > Back Up > Back Up To, are created wherever you specify during that process and are either regular project folders or compressed .zip versions of same, depending on which you specify during that process.

Where one should best locate each of these (project itself, auto-save backups, on-demand backups) varies depending on needs, personal preference, one’s backup strategies, locations, etc. The general recommendation is that project folders themselves should not be located in Dropbox unless there is a critical need to be able to directly edit them from more than one computer (taking pains to assure that only one computer has the project open at a time and that sufficient time is allowed for Dropbox syncing). Rather, the auto-save and/or on-demand compressed .zip backups are probably more appropriate to be in Dropbox. My personal practice is to only have on-demand compressed .zip backups go in the Dropbox folder.

Please see:

Also please see the following Scrivener knowledgebase articles:

Hope that helps.


Going by your screenshot, you are in fact too deep in the zip file. I’ve attached an annotated version of the image to help clarify this. You’ve already opened the .zip folder and are viewing its contents, whereas you need to right-click on the .zip folder itself in order to see the “Extract All” option from the context menu. That said, Windows Explorer does provide an “Extract” toolbar with the ability to extract files from the level you’re at as well.

Another option is to back up a level from where you are in Windows Explorer so that you are just inside the “” folder, with the “StairwayNo3-3-5-14-2.scriv” folder visible in the window (where currently you see Files, Settings, Snapshots, and project.scrivx). Then you can select that .scriv folder and drag it out of the Explorer window to drop in your Documents folder. Windows will extract the dragged folder as part of that process.

Here’s a link to Microsoft’s support article on extracting files in 8.1.

The Dropbox and sync options aren’t directly affecting this. No matter where your zipped folder is stored, you will not be able to open the contents in Scrivener without extracting them first. This has always been true, so I can only imagine that previously either you were not storing the backups as zipped files (there is an option for whether or not to do so when creating automatic or manual backups) or that the Windows 8.1 interface or handling has changed slightly so that whatever steps you used to take when opening the zipped backup also previously extracted the folder and now no longer do so.

In any case, following the steps to specifically extract a copy of the project backup from the zipped folder will solve the problem.

It appears that in some of the screenshots, the .zip file contents are being browsed/viewed from within an Internet web browser rathern than in Windows file explorer. Extract commands may not be available there… Or may be offered in a different location than in the file explorer.

I cannot express my gratitude for the help above, very very much appreciated. MimeticMouton - a million thanks for the annotated screen shot. And thank you for hanging in there with me. Springfield MH your detailed explication was incredible.

Despite my resistance to same (see below), I went ahead and extracted the file in Dropbox. Since I’m not used to doing it, I just hit “extract all” (those who are using Win 8.1 will understand) - from there it said it was extracting 172 items to the same folder that I was in. When it was finished, (it was quick), I couldn’t find the results - I looked in other places besides where it said it was extracting to. Sorry, I wish this were that simple. I will try again. though it all seems a bit worthless given my next question and what I’ve been experiencing up until a month ago. I am a webmaster btw, I really am pretty computer literate. Though it may not seem so at this time. :open_mouth:

I feel though there would be a lot more clarity for me at least, and possibly for everyone else, if we would focus on a critical question: If I’m too deep into the zip file when I click on the project.scrivx file, why does it work for me to do that from my PC or my external HD? (Innocent face)

Thank you muchly and kindly,


Glad we’re getting closer, anyway! I don’t have 8.1 to test on, so possibly something changed here, but in Windows 7 using Extract All, you’re prompted to choose the location where the extracted files should be saved. The default location will be the same parent folder where the .zip folder is saved, but in a new subfolder using the name of the zipped folder–admittedly confusing, especially when you have the file extensions hidden as you do (so you don’t see the .zip in the file name when you’re just browsing).

I strongly recommend choosing a different location for extracting the backup, somewhere a) not in Dropbox, preferably, and b) not inside the folder you use for your automatic backups. (I’m not sure whether the second point is applicable here, but I mean that if in Tools > Options: Backups you’ve chosen Documents\Backups as your project backups folder, don’t extract the backup into Documents\Backups. Choose somewhere else in your Documents folder to save it so you can open and work with it in Scrivener, to keep your backups folder purely for backups.)

I didn’t watch the whole thing, but here’s a YouTube how-to for extracting zipped files on Windows 8 that might be useful, since it will have the same interface you’re seeing. You can skip to 1:22 for the basic demo on extracting a zipped file.

Another option instead of the Extract All method (possibly covered in the video) is to instead use the drag & drop method of selecting the entire .scriv folder from within the .zip file and then dragging that to the location you want to save it, e.g. your user Documents folder. Make sure if you do that you drag the “StairwayNo3-3-5-14-2.scriv” folder–don’t dig into it and pull out individual pieces like just the project.scrivx or just the Settings folder.

As I said earlier, it has never been possible to open and work in a zipped file within Scrivener. Zipped files are read-only, meaning that even in programs that can open zipped files, e.g. you can view a zipped .doc file in Word, you cannot edit and save the changes into the same file. Scrivener needs to be able to save into the project folder from the point of opening in order to keep all files in sync, so it does not support a read-only mode.

All I can assume then is that from your other locations you’re not opening zipped files. In the Backup tab of Tools > Options, you can choose whether or not the backups should be compressed; if this is unchecked, then the backups are stored as uncompressed (unzipped) folders and you would be able to just open the folder, drill down to the project.scrivx file, and open it in for editing in Scrivener. Likewise if you’re creating manual backups via File > Back Up > Back Up To…; you have the option during the process to zip or not zip the backup. Since you’re working without known file extensions visible, the difference between a zipped backup and an unzipped backup is going to be much more difficult to notice at a glance:ZipVSUnzipped.png

The top one is an unzipped backup. The bottom one is zipped. Depending on the view mode you use in Explorer or on your Desktop, the only visual clue could be the icons. :wink:

Final comment and I’ll shut up. Don’t think I’ve got anything more to add to this discussion. Best of luck.

“If I’m too deep into the zip file when I click on the project.scrivx file, why does it work for me to do that from my PC or my external HD? (Innocent face)”.

A couple of possibilities that come to mind…

  • The apparent .zip is actually just a regular (uncompressed) project folder, despite having .zip on the end of its name. In that case, one could open the project. I don’t think there’s anything in Windows that refuses to let one add .zip to the end of the name of a regular folder, even though the result is misleading and confusing and it doesn’t cause compression of the folder into a single file to happen. As discussed, when click on a legit .zip in File Explorer, should see various visual confirmation that it is a compressed/zip file (“Compressed Folder Tools” appears in File Explorer title bar, type shows as “Compressed (zipped) Folder” rather than “File folder”, the .zip file displays a “folder with zipper” icon).

  • Some rare strange glitch or third party utility that attempts to support such (which might work for single simple file, but likely not well or at all for something as complex and multi-file as Scrivener). In which case, it is a bug, not a feature. Avoid and don’t depend on it. For confirmation that this has always been the standard, do a Google search on “edit file within zip” or something similar.

Thank you Jennifer! I’m not able to check on this and try it all right now, but will do so in a few hours. Will be back with results!

Jennifer, SpringfieldMH, I finally got back to this today and within moments had one of the Dropbox files extracted (to a folder named “[titleofbook]Extractions”. Works great. What a relief. Glad to be able to use the backups. Thanks for being willing to hang in there while we went back and forth.

:smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:

I still do not understand why files were saved directly, without zipping, in Dropbox and in Skydrive, as they are on my hard drive, up until a couple months ago. It would be interesting to know if anyone does have that information. If not, I’m okay with calling it a day (or a year or whatever!)

Blessings (angel smilie)