Can't Activate Scrivener 3 for Windows - StructureMap Exception Cod: 207

I had to reinstall my Windows 10 OS and now I’m trying to reactivate Scrivener 3 for Windows. When I try to do this, I get the Activation Failed message below:

Activation Failed.

There was a problem activating Scrivener. Please try again in a moment, or restart your computer and ensure it is connected to the Internet, then try again.

StructureMap Exception Code: 207
Internal exception while creating Instance ‘e8208c7c-2677-4cc0-b0e7-db907fc8d070’ of PluginType PaddleSDK.IO.IFile. Check the inner exception for more details…

This happened to me before, when I was running Windows 11. To resolve it then, I reset my local security policy to factory default and then activated before group policy could come in and set everything. That solution hasn’t worked for me this time.

Does anyone have any thoughts? I’ve already tried rebooting my computer (multiple times) and I do have a solid connection to the Internet.

Any help would be greatly appreciated.


Brian Schade

I was finally able to get my copy of Scrivener to activate. I’m not sure exactly what I was able to do to make it happen. I ended up running the following command from an elevated command prompt in order to clear out the local security policy and set it back to factory defaults.

secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

Also cleared out the local group policy by running these commands at the same time.

rd /s /q grouppolicy
rd /s /q grouppolicyusers

I have run this command several times earlier to no avail. It seems like on the third or fourth attempt, it worked. I still am not sure why now and not before. At any rate, things are as they should be. Now I am off to complete my book.

Thanks, everyone! I hope this solution helps anyone else who might also be running into this problem.


1 Like