Can't add a word to custom dictionary

The word I cannot add is
IS accepted as a spelling, so why is the possessive form not accepted? Neither ‘Learn’ nor ‘Ignore’ works for this word; each use of the word is flagged every time I run spell check. After searching advice in the forum I tried ‘unlearn spelling’ and then hitting Learn again, but that didn’t help. Any thoughts?

Yes hi.

The problem is with the curved ’

Type (not paste) the word in the synopsis panel – which is in plain text and has only straight ’
Right click → Learn spelling, from this panel.
After that you may simply delete the word from the synopsis panel.
The word will now be recognized.

Who would have thought: The same weirdo behaviour on Windows and Mac.

Well. I didn’t even notice this was categorized as Mac before you mentioned it.
So perhaps not. I don’t know.
But the possessive form (the 's) shouldn’t be considered as part of the word to begin with if you ask me, so if it was added to the dictionary without, it should work from there on anyways, ??

Vincent, thank you for your replies.
I’m afraid your synopsis panel suggestion did not work.
Also, as I explained in my question, the word without the apostrophe is accepted by spellcheck.

Can anyone help?

Have you tried adding it directly, in the options ?
I don’t know how much alike the Mac version is to the Windows’ one, but if the same, it’d be here :


If you open a program like TextEdit on your Mac and type the possessive form there, are you able to get TextEdit to learn that version?

Scrivener and TextEdit both rely on the macOS spelling and grammar tools, so seeing if that word can be learned in TextEdit could help determine if the issue is with the macOS tools or within Scrivener.

In other words, I’d expect TextEdit to show the same issues with learning the possessive form. If it also will not learn that word, it will give us some additional parameters for review.

You’re absolutely right, TextEdit is also unable to learn it.

Alas, in the Mac version I do not see a ‘View Personal Word List’ button on that page, and searching Help for ‘personal word list’ yielded no results.

Your user dictionary is hidden deep in ~/username/Library/Dictionaries/ but I don’t know if trying to open it is a good idea and I would be chary of editing it! This is on MacOS 14.2.1, by the way.

I’ve just tried (using Nisus Writer Pro, built on the same Apple TextKit and using the same Apple spell checking/learning as Scrivener). I typed “Kamāmalu”, “Kamāmalu’s” with a typographer’s apostrophe, and “Kamāmalu's” with a plain apostrophe. I then used check spelling, it learned the non-possessive, marked the typographer’s apostrophe version as an error, but wouldn’t learn it (just gave a ‘boingk’ noise), but marked the plain apostrophe version as good, without needing to learn it.

So what I think is going on is that the dictionary is set up to automatically recognise words ending with “'s” as possessive forms without having to learn them separately, whereas those ending with “’s” aren’t recognised but the base is so it appears not to want to learn them.

All that is down to Apple; Scrivener just calls the service as provided by Apple.

For many, many reasons, I use plain quotes while typing; don’t do spell-checking in Scrivener but compile to RTF; open in NWP, do spell checking and other routines there and convert to smart quotes when all is done.


Mark, thanks for responding.
If I’ve understood you right, you’re suggesting I use straight quotes rather than curly quotes. Is that correct? If so, can you tell me how to do this? And if not, what is the distinction between a typographer’s apostrophe and a plain one? Thank you.
Also, it is possibly worth mentioning that this prjoect is 120,000 words long, including many apostrophised words, and this is the only apostrophe Scriv won’t accept.

1 Like

Sorry, I was being pedantic… smart/curly quote/apostrophe is technically typographer’s quote/apostrophe.

Without reading your manuscript it is hard to know why this one only isn’t being learnt. Is this the only personal word in the text which has a possessive? Is this the only personal word in the text which has a vowel with a non-common diacritic, ā, as well as a possessive?

You have two options:

  1. Simply ignore the marking on this word (you know it is right) while uttering imprecations in the direction of Apple;
  2. Convert them all to plain quotes until you’re ready to compile, then convert them back to “smart quotes”—see Edit → Transformations.

N.B. Interestingly you can set Compile to automatically turm smart quotes to plain quotes, but not vice versa; I suppose the reason is that many people prefer them in the editor, but if they are compiling to MarkDown etc. they need to be converted and setting that in the Compile set up saves a lot of time and heartache…

As for using plain quotes etc., that is simply my preference, but it does involve a forgettable final step. I have smart quotes turned off in Scrivener → Settings → Corrections. But YMMV.



I don’t disagree, but imagine the level of frustration when attributing the possessive form of a proper noun to your characters and leaving the red squiggle? I, for one, am too ADHD to leave the “error”. It’s easier to add to dictionary.
Perhaps the Mac OP should use the Mac equivalent of Ctrl+Shift+Q (I have no idea what it might be) to change the document to straight quotes, add the word to the dictionary and then Ctrl+Q to change the doc back to smart quotes. (Yah, I found a use for Ctrl_Shift+Q. I can’t imagine anyone preferring straight quotes.)

1 Like

But I mean the “red squiggle” has no business being there to begin with.


As I pointed out, that is how the Mac dictionary seems to work, as long as it is a plain apostrophe on this word. The problem is that, for this word at least, the Mac dictionary doesn’t like the curly apostrophe, but I have no real idea why not; my best guess is that it doesn’t baulk at it for regular words but maybe for invented words, or for invented words with diacritics, particularly ones with a macron, which is not commonly found in loan words in English.

Note, on the Mac, the dictionary and the user dictionary is provided by the system, unlike on Windows, where the devs have had to set up Hunspell and include the “Personal Word List”.

My second suggestion. On the Mac, there is no shortcut associated out of the box with the
commands for converting smart vs plain quotes, but the user can set up their own shortcuts through system settings for the keyboard.

And, as I pointed out, once the root word is in the user dictionary, with a plain quote it is not possible to get it to learn the possessive form as that is already accepted by spell check.


1 Like

By ‘personal words’, do you mean proper nouns? If so, yes, other proper nouns have possessive apostrophes that do not get flagged. The only other macrons occur in Mō’ī’s, but this word is accepted by the spell checker.

It occurs to me that this fault only developed after I installed Sonoma. I’m running 14.2.1.

I meant words you created like the one in question, not proper nouns as such.

But the fact that Mō’ī’s doesn’t get flagged is interesting and puzzling. I cannot explain it; as I said, the problem also occurs with Nisus Writer Pro… mind you, to test it I copied and pasted from your post, so I’ll try again entering them properly with the appropriate unicode characters.

Can I ask… how did you enter the letters with the macrons?


PS: The plot thickens!

I opened a new document in NWP, typed in Kamāmalu, Kamāmalu’s, Kamāmalu's, then Kamamalu, Kamamalu’s and Mō’ī’s… and guess what? The only one that was flagged was Kamāmalu’s, even though Kamamalu and Mō’ī’s were not strings I’d ever used before so can’t have been in my user dictionary. Also weird was when I opened the “Spelling Window” (same window in Scrivener but called “Show Spelling and Grammar” in the menu there), Kamāmalu’s only was selected but offered me “Unlearn” as the option!

So, clearly there is something rather wrong with Apple’s spell check system! My two options remain. You could try complaining to Apple, but I don’t think it’ll do much good; people have been complaining about spell check for as long as I can remember.


By ‘words you created’ do you mean words I had to add to the dictionary? I don’t mean to be pedantic, but it’s a proper name, not a word I made up.

I entered the macrons by selecting them in ‘Emojis and symbols’. But typically I only did that one time; after that I’d type the name without the macron then use search and replace to ensure I’d spelled all the instances correctly.

Incidentally, I’m also using the 'okina, for example Ka‘ahumanu, and I have no problem adding apostrophes there.

I blame Sonoma… not that that helps me solve the problem!

Oh, I really am terribly sorry. I assumed that you were writing about a Tolkien-type created world, and not that these are names from a real language… I do apologise. Yes, I meant words you had to add to the dictionary.

In my extension to my last post, I entered all the letters with macrons from Emojis and Symbols.

It seems Sonoma has created many problems for developers dependent on TextKit.


FYI, the ever helpful Martin of Nisus said this in a response to a post on the Nisus Writer Pro forum:

There have been several periods of Apple triggered instability. So far Sonoma incompatibility has been a little rockier than in recent years of macOS system updates, but in the long view it’s not quite as disruptive as some of the bigger Apple transitions. Certainly the move from “classic” to Mac OS X was THE big one, but another big effort was the PPC to Intel transition.

Given the problems they encountered with Sonoma, I think the “little” is a slight understatement.