Can't Compile to Word Docs, HELP!

Hello all,

After recently updating to Scrivener 2.7.1, from the Mac App Store, I’m having a problem compiling readable Word documents, with either the .doc or .docx exporters. I’ve tried jimmying with many of the compile settings to see which ones might be causing the exporter to hork itself, but to no avail. Every time it produces a .doc or .docx, Word 2011, Word 2016, Pages 4.3, and Pages 5.6, etc., nothing will open it . . . they all say it’s corrupted somehow and bomb out. Any suggestions for fixing this?

—Andy H.

Have you determined if it is a problem with the software on your machine in general, yet? I would create a blank test project and type in a few words (rather than pasting them from the other project, just to be safe) then compile to .docx and see if that opens. If that works, try saving your compile settings from the main project, to a preset, then apply those settings to the test project.

If that all passes, it could be something in the project content—maybe a bad image, though it would be odd for Scrivener to pass over it while other things fail, usually its the other way around as the media libraries Scrivener uses are not as robust in those such as Word.

One other thing, you mention the .docx doesn’t work in these programs, what about Scrivener? If you drop the compiled file back into a Binder (the test project again would be a safer place in case it crashes) does it work?

I have the same problem. I can’t get Scrivener to compile anything. I tried a new test file. It just hangs.
I tried the synopsis titles setting and manuscript. It won’t save in ANY word docs, only Rich Text.


Unless your platform tag is set incorrectly in your forum profile, I doubt this is the same problem since this is a Mac thread. I’d be happy to move your post to the Windows area if need be.

No. I’m on Mac OS OX 10.11.1
Scrivener won’t compile to a word doc.

Okay let’s continue this in the thread you started then. The problem the original poster describes here is that the .docx file doesn’t open in Pages, etc., not that it simply doesn’t compile.