Can't delete old backups

I’ve got tons of scrivener backups and saves which I do not need.
They’re pretty big, too.
But when I try to delete them I get the message that they can’t be deleted because they are in use.
They aren’t in use. I haven’t used them for months.
How can I get rid of them???

Any reference to a file can cause it to be “in use.” So make sure Scrivener isn’t running, close down any Finder windows except the one you’re working in, etc.


Screen Shot 2012-05-27 at 2.12.16 PM.pngScreen Shot 2012-05-27 at 2.12.27 PM.pngScrivener is not running nor is any other app but finder.
Maybe this is because I have all my Scrivener files in dropbox and dropbox is running and constantly updating? NOPE. Quit dropbox and still got the messages, see attached.

Take a look in app monitor and make sure there are no hung scrivener processes.

Failing that, there might be a backup or other utility hanging on to them. You may find a system restart followed by an immediate emptying of trash the easiest solution.

In all such cases, and they happen with other apps too, so I guess it’s a system glitch, I have found shutting down, waiting a moment and restarting the computer solves the problem.

If you’re on Lion, quit all apps and make sure you set it not to re-open running apps before you do so, so it doesn’t restart the process that’s causing the problem!


Okay, I’ve tried everything that’s been suggested including deleting scrivener preferences, and nothing worked. Finally I actually looked at the files in the trash and discovered I had put them in a folder called “scrivener from dropbox.” Now, in my search for an answer I’d quit dropbox, so I didn’t see how that would be an issue, but I removed the files from that folder and was finally able to trash them. So the issue was never a scrivener issue, but a mac-trash-issue, and it’s been solved. Thanks all for the help. :blush: