Can't eject SCR USB file

Just got the USB “pill” in the mail and plugged it in. Everything works except it can’t be ejected while leaving the Scrivener file in Applications. I thought the pill could be removed from the USB port after the program is loaded. I’ve tried a few restarts. I’m using Safari 2.0.3. and OS X 10.4.6. What am I doing wrong? :unamused:

Hm. Could you describe what you’re doing and what’s actually happening? You should be able to copy the Scrivener program to your Applications folder on your hard drive and then eject the USB pill without a problem, so it’s strange that it’s not working for you. You do need to make sure that after you’ve copied the application to your hard drive, you don’t also have it open and running from the pill. The easiest way is to just make sure you’ve closed all instances of Scrivener, eject, and then start the program once the USB drive’s no longer plugged in.

Does it give you a specific error message when you try to eject that you could copy here?

The copy of Scrivener appears when dragged into the Applications menu all right, and works from there. I’ve registered my serial number, added the Extras, and accessed the tutorial. A bar for SCR USB and a bar for Scrivener with eject arrows appear on the left. If I click on the SCR USB bar eject arrow, a box appears saying it’s “in use” and can’t be ejected. ??? :cry: Maybe there’s some way to copy it, and then eject it?

Sorry if I’m being slow about this, but if you have both Scrivener and the USB device showing up under “Devices” with the ability to eject, it sounds like you’ve still got a file from the USB open and running. If you close and quit all the windows (including Scrivener and the finder window that appears when you first double-click the USB icon and any others you open in the course of copying the app), does the second “Scrivener” one still show up? Can you eject that first and then the USB?

If you’ve actually copied the Scrivener app to your hard drive’s “Application” folder, you shouldn’t need the USB drive in to run the program, you’re right. If it’s just a pointer to the real file on the USB drive, then it would cause a problem, but it sounds like that’s not the problem. You can double check by right clicking on the Scrivener file in your Applications folder and making sure it doesn’t say “alias” and doesn’t list a separate “original” file.

Try shutting down your computer, removing the pill, and then restarting and running Scrivener from the icon in applications folder. If it works, you’re good to go; if it tells you it can’t find the application, all you’ve copied into the applications folder is an alias to the version on the pill.


My advice:

  1. Make sure nothing Scrivener-related is running.
  2. Eject the ‘Scrivener’ thing first. (sounds like a virtual disk is mounted)
  3. Then Eject the USB device.


My arm-chair guess on this: What is on the USB pill is a Scrivener .dmg file. You put the USB device in. You opened the .dmg file there and this mounted a virtual disk. The Scrivener app appeared in the window for that virtual disk. You drag-copied the app to your Applications folder. But you now have two ejectable devices showing: the USB device and the ‘Scrivener’ virtual disk mounted from the .dmg file. Since the virtual disk is a virtual construct from the .dmg file on the USB device, you cannot eject the USB device, because the .dmg file on it is busy. You must eject the ‘Scrivener’ virtual disk first, and then you should be able to eject the USB device.

I am speculating, since I’ve never had the pleasure of having a Scrivener pill. But it makes good sense of what you are saying you are seeing.

Thanks for you help so far. I’ve made some progress. You’re right that the Scrivener file with the eject arrow on the left side of Applications must be clicked on first, and the Scrivener ap logo removed from the desktop (after it’s been dragged into Applications). Then the SCR USB can be ejected, and its logo on the desktop removed, supposedly leaving the clean copy in Applications. I’ve done this, but now when I click on the Scrivener logo in Applications, it says “the Volume for Scrivener cannot be found”. :neutral_face: so I’m assuming it’s somehow not winding up where it should be. Am going back to try to trace where it should be now. Anybody got a candle? :bulb:

Sounds like it just never got copied to the hard drive. Before you plug in the USB drive again, you could do a spotlight search for “Scrivener” and see if it comes up with anything (the real application package, not an alias), in case it just got misplaced to another folder. If that’s the case, you can just move it to the appropriate place. If nothing comes up, you’ll need to reinstall it: plug in the USB again, mount the .dmg file, and then drag the Scrivener app to your computer’s application folder. Eject disk image, eject USB drive. Launch Scriv, write masterpiece. (Or so we hope!)

Edit: Be sure you’re not dragging the Scrivener app to the Applications stack on the dock. I’ve done that accidentally and it acts like it installs but it doesn’t really, so it leaves a ghost icon but won’t run. If that’s the case, delete it from there and reinstall, dragging it to the Application folder in the Finder.

Bad news. It looks like there are two SCR USB files or the pill has become corrupted somehow. It will only load an alias of Scrivener. Have tried shutting computer down, ejecting and re-installing, but it’s not working. Thanks to all for your helpful suggestions. Scrivener is still a great program. In the words of Arnold: “Ah’ll be back!” :wink:


There should be three files on the Scrivener USB Pill:

  1. Scrivener.dmg
  2. ScrivenerHelp.pdf
  3. Installation.rtf

The Installation.rtf contains (along with a link to videos) the following:

  1. Double-click on Scrivener.dmg (DMG = disk image).
  2. This will open a licence agreement window. Once you have read through the licence and checked that you aren’t signing away your firstborn, click to agree to it and a corkboard window will appear with three icons on it. Because it is a disk image (a virtual disk), an icon will appear in the “Devices” section of the source list in the Finder, too.
  3. With the Finder open in the background, drag the black and white Scrivener icon from off the corkboard window and drop it into your Applications directory in the Finder.
  4. Double-click on the Extras Installer icon and follow the onscreen instructions to install certain extras, such as project templates.
  5. Once that is done, you can click on the eject button next to the Scrivener disk image icon under the “Devices” section in the Finder.
  6. Launch Scrivener directly from your Applications folder (do not run it from the USB drive). If you wish to have Scrivener in the Dock, just drag Scrivener from your Applications folder to the Dock (do not drag Scrivener directly from the corkboard window into the Dock - you must drag it into the Applications folder first and then from the Applications folder into the Dock).
  7. When you first launch Scrivener, you will be informed that it is the trial version and that it will expire after 30 days. Click on the “Enter Licence” button and enter the name and serial number found on the back of the card to which the USB Pill was attached. (Alternatively, when Scrivener is running, you can go to Scrivener > Register… to enter your serial number.) This will unlock Scrivener so that it becomes the full, unlimited version.
  8. Once everything is installed, you can eject the USB Pill.

There shouldn’t really be any need to send the Scrivener USB Pill back, as the important file (the Scrivener.dmg) can be obtained from our website. Simply go to Once you have Scrivener installed without the confusion of a mounted USB drive muddying the waters, you can tidy up your USB Pill with the downloaded Scrivener.dmg and ensure that the Pill only has the 3 files initially mentioned.

I hope this helps you get up-and-writing in the cleanest way possible.

All the best,


Good advice. I’ve tried shutting down and re-booting. I realize now that after the SCR USB icon appears on the desktop, I need to eject the Scrivener icon first, then the SCR USB icon, after dragging the Scrivener icon into my Applications folder and installing it there. That all goes well,(the Extras installation seems to load OK too) but after the pill is ejected and taken out, when I go to open Scrivener, I get a box that says “The volume Scrivener cannot be found.” constantly, regardless of restarts or rebooting.

In the “Disk Utility” function, I see two versions of the SCR USB files, one for the device itself, and one for the program on it. When I look at the program, the first line of its description seems to be repeating itself over and over, each line fading into the next. The “Info” box describes the Scrivener program as an alias. This is why I get the “volume cannot be found” message, I think.

All very frustrating. The pill has become corrupted somehow in transit is my best guess now. Nobody’s fault really. The reason I bought it in the first place is I’m wary of downloading on my sometimes unreliable dial-up connection, and wanted to have the pill around for a backup just in case. I’d still like to have a working pill. I’m willing to pay return postage. Scrivener, as a program, looks like it’s worth it. Thanks for your help.

I highly doubt that it is an issue with the USB drive itself, since you already mentioned that when it is plugged in you are able to load Scrivener just fine. If it were corrupted, this would probably not be the case. Instead, for whatever reason it sounds like whenever you drag things to your hard drive from a read-only drive, they don’t actually get copied, you get an alias.

You can attempt to force a copy move by holding down the Option key while dragging. You’ll know this is working if you see a little green dot with a plus sign in it, in the corner of the icon you are dragging. You should always see that when dragging between volumes, incidentally, but for some reason you might not be.

But again, I don’t think it is a problem with the drive itself. I have never heard of a case of corruption which causes a Macintosh computer to make things drag as aliases instead of the original file. That would be awfully strange, bordering on magic. Now, if you copy Scrivener over correctly, and eject and then double-click on it and it doesn’t run, then you might have cause for returning it and trying a new one.

Hi, V5Tate,

Glad you got the ejection problem squared away. now, about the aliasing problem:

I suggest you do a Get Info on the Scriv app file on the pill to see if what is on the pill is itself just an ALIAS. (You want to do the Get Info on the file that you are instructed to drag to your Apps folder.)

A) If it is an ALIAS, then a mistake was made in loading the software onto the pills. And Lit & Lat will be anxious to correct this.

B) If it says it is an application, then we must conclude that the problem is not in the pill, but that the alias is being created somehow by your drag and drop operation. And our job is to figure out how that is happening so you can get up and running.

Just to leave no stone unturned about the file copy process, here are two things to note:

  1. The Finder makes aliases when you hold down both the command and option keys while dragging a file somewhere, so don’t hold those keys down when dragging. You should see the green plus symbol appear before you drop.

  2. The Finder also makes aliases when you drag something onto the Dock (or a group on the Dock) or into a Finder window sidebar. So don’t do either of those things. Drag the Scriv app into an actual folder.


You say you copied Scrivener to your applications folder… but is it possible that you just dragged the Scrivener application to your dock? If you do that, then it’s just a shortcut to the application on the USB drive. If I’m right, then try this:

Open a finder window. Navigate to the Applications folder there.
Plug in the USB pill. When a new window pops open showing the Scrivener application, drag Scrivener from that new window to the other Finder window displaying the Applications folder.

Eject the DMG and the USB pill, go to the Applications folder in your Finder, locate and launch Scrivener.

Hope that helps. If it doesn’t, I was never here.