Can't launch Scrivener ("damaged or incomplete" error)

Hello. I am on a deadline and working on a novel – foolishly did not back up to Word yesterday as I usually do and now I don’t have a copy of my last 3000 words. I saved my work last night on Scrivener and closed my Macbook. When I click on the Scrivener icon in Launchpad it says “You can’t open the application “Scrivener” because it may be damaged or incomplete.”
When I search the name of my project or the Scrivener tutorial file in Finder, it brings up a black box down in the icons row called Terminal, and a small box pops up on the screen that says:Last login: Tue Aug 2 09:23:52 on ttys000
Candaces-Air:~ candacecox$
The title line of that box reads Candace Cox - Bash - 80 X 24
I don’t want to uninstall and lose my work!
I’m not computer savvy and I’m on a deadline.
I tried typing powershell into Finder and nothing came up.
Hoping someone can help!!!

(Moderator note - Moved topic from Windows to macOS support.)

First thing to try is just reinstalling the application. Your projects are saved separately, so they won’t be affected by the process. The steps are a little different depending whether you bought Scrivener directly from us or via the Mac App Store, but this knowledge base article covers the instructions for both. (I know the problem on your machine may not have been related to an update, but reinstalling as described is still applicable.)

I am very, very happy to say that I posted a help request on the Scrivener Facebook page, and within 30 minutes David had sent me a link to reinstall……. It worked! I’m so grateful and happy! Thank you.

Thank you, MM, you’ve just hauled another unlucky writer out of the brown smelly stuff! May the city of rain treat you to a dry day! Seriously, thanks. :smiley: