Can't launch Sente 6.6 with ⌘Y

I’m running Scrivener 2.4.1, MAS version. I use Sente as my reference manager, and have recently upgraded to the Sente 6.6 preview (version 6.6.2 to be precise). I’ve found that since upgrading, ⌘Y no longer works to call up Sente from within Scrivener; instead I get a message headed, “The bibliography/citation manager could not be launched.” The message mentions a potential sandboxing problem and suggests launching Sente 6 once and trying again, but I’ve done this repeatedly (including with Sente open) and it continues not to work.

I’ve tried resetting the citation manager in preferences and pointing it to Sente again, to no avail. Also, on the advice of a thread in Sente Support, I’ve tried renaming the Sente package to just Sente (mine was originally called Sente 6), which has helped other people, but this didn’t work for me.

I hadn’t realized how much I rely on moving seamlessly between Scrivener and Sente until it stopped working, so I’d appreciate any help anyone can offer!

To make sure it is purely a Sente issue, have you tried setting your bibliography manager to some other application in Scrivener’s preferences, to see if Cmd-Y will bring it up? It can be anything at all, even just Calculator.

Have you tried dling the non-MAS version of Scrivener ( and seeing if that works? As long as you’ve run the Mac store version at least once it will recognise the license, and if it’s a sandboxing thing, using the non-sandboxed version of Scrivener might help. :slight_smile:

Oops – I thought I had alerts turned on and didn’t realize I’d gotten replies. Thank you for your speedy advice. I can set Calculator as my bibliography tool and launch it successfully, and the Sente problem persists in the non-MAS version. So this means it’s a Sente problem? I’m puzzled, because Sente itself launches just fine when I run it myself from Applications; what’s different about the way Scrivener is trying to launch it that would cause it to fail?

Thank you both for your suggestions.

Is it only launching that doesn’t work, or any activation at all? If Sente is already running, does it come up to the top when pressing Cmd-Y? As far as I know the launching should be roughly similar to double-clicking on an icon in Finder. You could try dropping Sente into a References list in the Inspector and see if it opens from there via double-click.

But the main thing I would suggest at this point is to run Console and see if you get any error messages while trying.

The problem solved itself in the course of the steps you recommended. I don’t quite understand why that solved the problem, so I’ll explain what happened in case it’s useful to you down the line (or to anyone else with this problem).

The problem before was that no activation at all was working; not only would Sente not launch, but I couldn’t switch to it with ⌘Y if it was already running. (My temporary solution was to run them both in fullscreen, swipe from Scrivener to Sente, and ⌘Y back from Sente into Scrivener.)

As you suggested, I dropped Sente into a References list and attempted to launch it from there. Scrivener gave me a message about needing permission to access files in a particular location. Unfortunately I didn’t take down the exact message, but basically it told me that it was authorized for this session only and if I wanted to authorize it permanently I should add it to the Authorize Folders list. Then Sente preceded to launch and Scrivener popped up the folder list for me to modify.

I thought perhaps I needed to authorize the Applications folder, but I decided to see if now that I’d launched it successfully once, it would work again without my making any changes. So I dismissed the folders popup and tried ⌘Y, and it worked. I’ve restarted both programs, and rebooted my computer, and it keeps working fine.

So, to recap, the problem arose without my making any changes to Scrivener (I think it happened when I upgraded Sente), prevented me from launching or activating Sente from within Scrivener, and went away when I dropped Sente into a References list and launched it from there. Now it works properly.

Makes no sense to me, but I’m happy that it’s working – thanks so much for your help!

That makes no sense to me either. :slight_smile: It’s truly strange that the direct-sale version did not work since everything else about this smacks of Apple’s sandbox technology, which is still rather full of bugs that can cause weird things like this to happen (and the direct-sale version doesn’t use sandboxing). But it must have been something else, oddly enough, since you tried the direct-sale version.

I suspect the warning message you saw was just the standard “first click” warning we give to people that have never used a form of linking before with the MAS version. Linking doesn’t work well unless authorised folders are set up since your project otherwise only has permission to use linked files for the one session.

Well, at least it is working now!

Okay, another wrinkle for you. My problem came back today. As far as I can tell, it came back mid-session; I’m fairly certain ⌘Y was working fine for me earlier in the day, and I haven’t closed Scrivener, but when I came back this evening I was getting the same message again. I tried the same solution as before, dropping Sente into a References list. I was able to launch it successfully from the References list, but not with ⌘Y, which seemed particularly odd to me.

I still had my dmg of the non-MAS version from earlier, so extracted it. (I renamed the bundle to Scrivener Web and added it to Applications, so I have both the MAS and non-MAS bundles listed as separate applications.) I ran the non-MAS version, tried ⌘Y, and this time it worked. Then, out of curiosity, I closed that version, fired up my MAS version, and tried ⌘Y – and it also worked in the MAS version. For the time being, it’s working in both copies of Scrivener.

The inconsistency of this behavior is what puzzles me. Is there any logic for this? Some external settings file that both the MAS and non-MAS versions would look to?

I came across the issue today. I had earlier replied at Sente’s forums that renaming the application works as a workaround. It still does, but the behaviour is erratic nevertheless. If named “Sente 6” any version of Sente will start as expected, including the newest release. But, if named “Sente 65”, “Sente 6.7” etc., it won’t.

Did you, at any point, reset the Bibliography Manager setting in the Scrivener -> Preferences -> General pane? It could be something as simple as that setting pointing to the old version, and therefore not activating the new version.


Hi Katherine,

No, I had not. Doing so did not alter the behavior. “Sente 6” works, “Sente 65” doesn’t. Playing around with applescript in order to figure out whether I could call “Sente 65”, it turned out that this doesn’t work either. Instead I am asked to pick the application from the list of available applications, within which it is duly listed as “Sente 65”. Picking “Sente 65” from this list creates a “Sente 6” entry in applescript.