Can't open restored Scrivener projects

The scenario: MacBook stolen while on vacation, replaced with new one. Successfully restored documents from DropBox backup. Downloaded Scrivener, successfully registered with old serial number (found among DropBox docs where it should be). But when I try to open any of the .scriv projects, either from within Scrivener or by clicking on them directly, I get the same message: “Project not found. No project could be found at the specified path.” And then a second box pops up: “The document ‘OldFile.scriv’ could not be opened. No valid project could be found at the specified path.”

It may be that when I get home and restore from Time Capsule, everything will work as it did before. But that’s a couple weeks away, and I don’t understand why it’s not working now. The restored .scriv files are all as large as they should be – 9MB, 3.8 MB, 400 KB – so they’re really there, but Scrivener won’t open them. Help!

First, ctrl-click on the .scriv project in the Finder and select “Show Package Contents”. Ensure that the binder.scrivproj and info.plist files are inside the project. If they are, it may be as simple as a permissions problem. It may be that the project still has its permissions set to the old computer, so the main binder.scrivproj file can’t be opened on your new machine (which would cause the error you are seeing). If that looks like the case, try the following:

  1. Create a new folder in the Finder.
  2. Copy the contents of the .scriv file (the stuff that appears in the “Show Package Contents” window) into the new folder.
  3. Select the new folder in the Finder, Get Info, check the permissions and change them so that you have permissions to read and write to it.
  4. Click on the gear icon at the bottom of the Get Info panel and select “Apply to enclosed items”.
    (Note that to change permissions you may need to click the unlock icon and enter your admin password.)
  5. Add the .scriv extension to the new folder, to turn it into a Scrivener project, and try opening it.

The only reason for the rigmarole above, by the way, is that the “Apply to enclosed items” option is only available for folders and won’t appear for the .scriv file unless it has been turned into a regular folder first.

Hope that helps.
All the best,

Thanks for the help, Keith. I went through the steps you outlined but unfortunately, trying to open the file afterwards produced the same result. When I checked the permissions for the new folder, the Get Info window said I already had permission to read and write, so I guess that wasn’t the problem after all. If you have other ideas I’ll try them, too.

Fortunately, this isn’t extremely urgent. I’ll be able (I hope) to restore from Time Capsule when I’m back home in a week, and in the meantime, I think all but one file I need to use also exists as an rtf document that was included among my restored Dropbox docs, and it appears that I can open those in TextEdit and Bean. I’d decided a few weeks ago, after the slowdowns reported here (and that you’re fixing for 2.0), to use Scrivener only for actually drafting stories, not storing files, so I’d exported just about all my research files (for 2010 stories) and drafts to the Finder. It helps that this is the end of the year, and I have only one more 2009 column left to write, and that’s the one whose research I need to retrieve from my 2009 Scrivener file for that publication in the next few days, so I hope someone can help me figure out how to open that lone remaining 2009 .scriv file. Thanks!

Perhaps AmberV’s advice in will prevent a similar problem in the future.


Yes, but did you still go through and set it to have the same permissions for enclosed items? The newly-created folder would of course have the correct write permissions, because you just created it using your current account. It’s the contents of that folder that you want to fix the permissions for. So, if you didn’t do it already, as I said before, Get Info on the folder, unlock it and then select “Apply to enclosed items” to apply your write permissions to the contents of the folder.

(Before doing this, you might want to check the permissions of the binder.scrivproj file inside; I’m guessing it doesn’t have the right permissions - also, you didn’t mention whether it exists or not; I said to ensure that it exists, because that is very important for the integrity of the project, is it there?)

Apologies if I misread your reply or I was unclear before, but from what you say it sounds as though you didn’t follow all the steps I provided, and you will need to in order to sort out the permissions.


Thanks, Keith. sorry I wasn’t clear: yes, I did do all the steps you suggested the first time, and just did them again – same sad result. I also checked the permissions for the binder.scrivproj file (actually, files – there were two, each named “conflicted macbook file” or some such, each followed by a different date), and it said I had read and write privileges, too. so maybe it’s not a permissions problem?
The files are clearly there, all 18 MB of them. I only need about a half dozen of them, out of over 1000 in the project, all of which have generic names like “1038.rtfd,” so I guess I’ll just go poking around through each of the rtfd files – maybe the last 50 or so, since they appear to be numbered in chronological order – and see if I can find the few I need with Spotlight or just opening the last few dozen files individually , using Bean or TextEdit.

AS I said, this should all sort itself out when I get back home and can restore from time capsule, but I’m happy to try other methods during the meanwhilst, as the Pythons say. But please don’t go to too much trouble advising me as I can probably track down the files eventually.
Thanks again for trying to help – can’t imagine many other developers who’d go to this sort of trouble for what’s obviously a rare occurrence.
Also, this incident has made me grateful for Dropbox and (I hope) Time Capsule, and I urge my fellow SCriveners have them or other comparable backup plans in place.

Wait, this is interesting. There should be one binder.scrivproj file and it should be called only binder.scrivproj - nothing else appended to it. Otherwise it won’t be found, so that would explain why you are getting the “project not found error” - there is no file with the exact title “binder.scrivproj”. From what you describe, it sounds as though whatever synchronisation/backup software you use has tried to merge different versions of the project and has thus renamed files within it so as not to overwrite them (I have seen this before). Because .scriv files are really folders of files, backup/sync software will often treat treat them as folders and think nothing of renaming files within them to avoid conflicts unless you tell them not to. But of course, if the files get renamed, then Scrivener can’t find them.

The next step would be to make a copy of the project and then to look through the contents of one of the copies looking for other obviously renamed files (that is, stuff with “conflicted macbook file” at the end or whatever, stuff that must have been renamed by your backup software). Try renaming the latest versions of the files to what they should be - e.g. change the most recent version of “binder conflicted mackbook file.scrivproj” or whatever it’s called to “binder.scrivproj”. Then try opening the project again.

All the best,

I don’t want to freak you out, but Time Machine is also known to corrupt Scrivener backups. The common wisdom seems to be that you have to use the built-in “backup project to” function in Scrivener (with the ‘Backup as .zip file’ option checked). I know that this kind of defies the purpose of having an automatic backup tool, but it’s probably the best way to make sure that your backups are safe. :cry:

Sorry I’ve been offline a bit and couldn’t update the sad saga of attempting to recover my purloined MacBook’s docs till now.
Keith, I searched the pacakage contents of the recovered Scrivener file and found a few “conflicted macbook” items. Most were titlted “ui (bretts-macbook’s conflicted copy 2009-08-14).xml” or something like that. Only three were binder files. I followed your instructions and changed the file name of the latest from "binder (brett’s conflicted copy 2009-08-14).scrivproj to just “binder.scrivproj” – and voila! the project opened in Scrivener.

The good news ends there. Unfortunately, as the date indicated, the named files within the project (i.e. research and draft) only went up through mid-August. The other files were still there, but just had numerical titles and appeared in a new binder folder called “Recovered files.” So I still wound up having to poke through a bunch of files that had only numbers as titles rather than the file names I’d given them. However, since the file names were evidently numbered in chronological order, I didn’t have to go through all 1000 of them, or rather chose not to do so; I just skimmed through the last few dozen and I think located all the files relevant to the column that’s due today. I found only a couple, and I sure hope I didn’t miss any.

I have no idea why the latest date of the binderproj file was back in August. Signinstranger may be onto something with the Time Machine corruption issue there, but then again, the Dropbox docs I downloaded and am working with should be coming directly from Scrivener, not via Time Machine. (I’m still traveling and haven’t had a chance to recover files from Time Capsule yet; still holding my breath on that one, because most of my music and other non-docs was backed up on TC, not Dropbox.) Evidently Dropbox is actually backing up/syncing my Scrivener and other docs, because the actual underlying files up through the day the MacBook was stolen are right there, and I’m grateful for that. But I know naught about the nuts and bolts of Scriv (or anything else about software, for that matter), so I can’t figure out why the recovered project doesn’t have the most recent binder file names.

At any rate, though it took a lot longer than it should have, and I might have missed a file or two, as far as I can tell, I was able to recover my info, but it’d be great for anyone else encountering this problem if the Master of Scrivener can figure out what went wrong. Maybe it’s a Dropbox rather than Scrivener issue? Back to you, Keith!

I’m afraid I’m no wiser than you on this one. There’s no reason Scrivener would revert to an earlier version of the file - the fact that there are conflicting file names there suggests that some synchronisation software - Time Machine or something else - has been involved, and my guess is that whatever that is is to blame, but that is just a guess I’m afraid. I would need to know more about your set up, really. Is it possible that the person who stole your computer could be in any way responsible, given that the Dropbox folder would be accessible if they could access your files?

Yeah, along with reporting my info to the insurance company and police, changing passwords, etc., I did actually wonder what would happen if the thief scum didn’t wipe the hard disk when they tried to resell my Mac. I just haven’t had time (being on vacation and all while trying to keep up with a couple of regular assignments back home) to inquire further with the dropbox folks what I should do now. Is dropbox trying to sync to my new and old computers? I took the precaution of moving the downloaded docs to a new folder on my new MBA, so they’re not only in the dropbox folder, in case something happens with the stolen Mac that would somehow cause Dropbox to delete the docs in the Dropbox folder.
That said, it would be odd if only those SCrivener files, among all my other thousands of docs that Dropbox apparently (not that I’ve checked every one of them, of course) did successfully backup and restore, were somehow messed with, even inadvertantly, by the thieves. Not that I know anything about this, but it seems likelier that something odd is happening when Dropbox backs up my SCrivener files, and somehow not everything is quite getting copied properly.

I guess the lesson is twofold: cloud backups like dropbox are really important, and I’m glad I had access to them for this and a couple other projects pending my return home to what I hope will be a safe and happy reunion with my time capsule. And second, as useful as they are, even the most seemingly secure online backup may still prove imperfect, so we should take precautions accordingly. I guess that means burning backup CDs again, or getting MObilMe again, so I have more than Dropbox and Time Capsule.
Anyway, thanks again for the assistance. IF there’s any way I can help you use this experience to make SCrivener even more reliable than it is, do let me know. And if any Dropbox users out there in SCrivenerdom can advise me about how to de-sync my stolen computer from Dropbox backups whilst retaining its link to my new one, please do.
Oh, my other advice: make sure your homeowners insurance or equivalent covers replacement value. My astute wife made that happen a few months ago, and I’m grateful, because it paid for my involuntary upgrade to this terrific previous generation MBA with SSD, available at a very nice discount now via Apple store’s refurb section. And save your receipts for stealable hardware. Thanks all.

I don’t use DropBox, but can’t you just change its password? That would break the sync for your former computer – since the thief wouldn’t know the new password – but leave it intact for systems you still control.

(And if it’s NOT possible to lock out a “rogue” computer in this or some equally obvious way, then DropBox is so insecure as to be unusable for serious work.)


Thanks, kewms. Yes, after writing that post, I headed over to Dropbox’s site and both unlinked my old computer from Dropbox AND changed my password. So that should stop any interference from the pilfering swine. However, it says the old files will be left on the purloined MacBook, and I don’t know of any way to have Dropbox erase them.

You probably could have “erased” them by moving everything out of the DropBox folder to another spot on your computer and then waiting a week or so. This would have triggered a delete state, then change the password and unregister the stolen computer. It’s too late for that now though, as you have to register the computer from that computer.

But it is probably a good idea to change all of your passwords. They’ll be able to access your browser history and all that entails.

Thanks, Amber. That;s good to know for future reference, and info I hope I NEVER have to use!

I have read about security services that can remotely wipe stolen computers. Corporations use them for employee laptops. I doubt there are any that can go in after the fact, though. You’d need to have the software installed before the theft.


I did this and it worked beautifully! Thank you so much. I thought I had lost an entire novel.

Glad that was of use! Permissions can be really problematic. I’m not 100% sure Scrivener is doing everything it can to ensure permissions are correct, and have this on the list to investigate for 2.0.

Thanks and all the best,