Can't remove double spaces between some paragraphs

Hi folks, bit of a Scrivener noob here. I’ve got a weird problem with Scriv 3 on windows. There’s a 1.5 space, or double space, between seemingly random paragraphs across my project. I try to hit backspace at the start of the second paragraph to delete the extra space but it won’t even let me delete. All spaces are set to 1.1 line space. The Text Tidying function is incredibly buggy and randomly deletes the first few paragraphs of the selected document, so I’d rather not use that anymore. When I select Show Invisibles, the line spaces in question look no different than all the other normal line spaces. So wtf? what’s going on?


You mention the line spacing; the editor also supports paragraph spacing. Try selecting the range of paragraphs, opening Format ▸ Paragraph ▸ Line and Paragraph Spacing... and setting the before and after paragraph spacing to 0.

If that doesn’t fix it, do you see any oddities (extra characters, for instance, or paragraph markers unusually placed) if you turn on View ▸ Text Editing ▸ Show Invisibles?

The “Line and Paragraph Spacing” suggestion didn’t do anything (they were already set to 0).

As for what I see in Show Invisibles, there is a tiny little vertical dash on the far right side of the editor where there’s an unwanted double space between paragraphs. But I can’t for the life of me figure out how to delete it. Help?

Also, how did it even get there in the first place?

(does anyone else find Scrivener’s formatting functions to be overly complicated?)

Any chance you could share a screenshot of the editor with those characters displayed? I’m having a hard time thinking up what it might be that you’re seeing. Was the text originally copied from another location (Word doc, website, etc)? That’s the usual way that unexpected invisible characters turn up, especially when copying from webpages. Paste and Match Style will strip source formatting when copying and pasting, but actual invisible characters can stick around through that.

If you right click in a paragraph with the spacing problem, are is the “Table” option available at the top of the context menu? If text was placed in a borderless table (or one with white borders that aren’t showing) that might be affecting spacing. In that case, copying the text from the table, then deleting the table and re-pasting the text should fix it. If the table properties aren’t available from the menu, though, then there’s no table at that point in the text.

When can see an example of the problem on the third paragraph down, starting with “When…”

I might have copied some text from, say, notepad or something similar, but never from webpages. It’s all original content.

Did you try checking for a table? The placement of the paragraph marker before the “When” in the third paragraph and the increased indent for that and the following paragraphs compared to the two above, make it look as though all that text might be inside a table cell. Try placing the insertion point in the third paragraph, then right-click and see if the Table ▸ option is available at the top of the context menu. If it is, selecting Table from its submenu should allow you to apply a border so that you can see the table in the editor. From the Table submenu you can also choose Remove Table, which will leave the table’s text content in place (each cell would become a new paragraph; in this case you likely only have one cell, so the text will stay pretty much as it is.)