Can't seem to convert to Docx File

I’ve been unable to convert my scrivener files to Microsoft Word docx files. It seems to go to a FileConverter1_6 error and it appears there’s something off with Java. I’ve reinstalled the latest Java modules, so I’m not exactly what to do. I have attached a PDF file of the Problem Report. Hope to hear from someone soon as I desparately need to convert my work to Microsoft Word.

What version of Scrivener do you have?

What specific Scrivener command are you using? Compile or Export?

If you have a copy of Word, the easiest alternative is likely to be to compile from Scrivener to RTF format, and let Word to the conversion to DOCX.


PS FYI, I deleted your post in the Support forum as a duplicate.

Sorry about the duplicate. Didn’t know where to post exactly.

I’m using the latest Scrivener edition. 3.03 (3032)

Both compile ande export don’t seem to work. It’s strange because I’ve never had problems before.

The problem with RTF files is that they don’t seem to incorporate Chicago-style footnoting. I could try again. But when I tried last, it didn’t translate the RTFwell.

One option that’s provided some measure of success in converting to PDF and get the PDF converted to Docx. But that makes things rather complicated. And the docx file is filled with errors.

I’ve reinstalled Scrivener, Word and Java and still no success. Hope to hear from someone soon.

Actually, nevermind. Saving it as RTF worked! Not sure why it wasn’t working before. But maybe reinstalling the app did the trick.

Still, I think this is a bug. The inability to convert to Word is important for folks like me.

Please look over the log file I sent in my first post. Once you have, out of privacy concerns please take it down, and delete it, if you can. I don’t know if I can do it myself, but once you’ve received the file, I’ll see if I can’t do it myself. Otherwise, please take it down.

There’s nothing useful in the log, unfortunately, other than a bunch of system process stuff, so nothing to give a clue. FileConverter1_6 is the Java class that Scrivener uses to convert RTF to DOCX, so it sounds as though something is going wrong there. Is this happening with all projects or just one? If it’s only happening with one, could you please zip up and send us the project?

It’s happening with all my files. I can’t convert ANYTHING directly to docx file formats. Do you still want me to send you the file? If you do, what email do I send it you?

I was thinking…is there a way to reinstall FileConverter 1_6? I tried googling it to no success. Is there anyway you guys could perhaps get in touch with the folks at Java? Just a thought. I might do it myself but alas, I’m busy.

Also, I vaguely remember (it’s been a long while since I posted to the forums) about their being “gifts” (ie free copies of scrivener, etc) for those who spot out bugs in Scrivener. I’m wondering if any deals are available, as I think this bug is fairly significant. :open_mouth: