Can't set Compile flag at Folder level for some folders

My manuscript structure is very simple - Book → Chapter → Scene.
My most recent compile omitted two chapters, and on investigating I discovered I couldn’t always set the Compile flag for those chapters at the chapter level. Any attempt to select the folder showed the metadata of the last selected scene (document) within that chapter, rather than the metadata associated with chapter (folder).
It seems completely random - selecting some folders will display their metadata just fine, while others insist on displaying a contained document. It’s making compile very unreliable.

You have two options.

Option one : go to the options and check this one setting :

That will make the parent folder/document reachable in a scrivening.

. . . . .

Option two : for those parent documents that persistently only display their enclosed documents, see that they are not set to display as a scrivening :

Scrivening : image

Normal : image

(Right click the paper icon in the document’s header.)


In your specific case, you do not want them to have their view mode locked.

Thanks! Applied those changes, which helped. None of the parents were set to display as scrivening, but toggling the “view documents on the corkboard” option – which you’d drawn my attention to – allowed me to access the folder metadata. Problem solved :slight_smile:

Hmm. OK :slight_smile:
To be honest, I am quite confused by your answer.
But if it works for you, well then, I guess that is a good thing. :wink: