Can't Switch Between Docs in a File

Ummm… this is not good.

I have a large-ish Scrivener file in which I keep all my personal journals. Here we are in November - nearing the end of a calendar year - and something has gone disturbingly haywire in the file.

When I select a document within the file from the Binder, the window does not switch to that document. This appears to be the case throughout the file.

I am reasonably certain the data is still there. There are a few documents that come up when I click the left/right arrows at the top of the the window I’m working in, and the content in those docs shows up.

But when I click on a doc in the Binder, the window does not change,.

This is making it impossible to retrieve most of the material in the file.

I opened the most recent backup - same issue.

I resaved the file and then did a Force Quit, which causes the Indexes to rebuild when it reopens the file. Same result.

I fear the file is irretrievably corrupted and I will never be able to recover what amounts to nearly a year’s worth of work.

Please advise.

Thanks,

–PS

I’m assuming this isn’t an issue with the ‘block position’ option (which makes a document remain in the editor no matter where you click on the binder).
Does it at least let you export your work? You could try and export it all (to word or rtf or others) just to have a backup in case no one comes up with a solution.

As @Ainoa already mentioned: Check that you don’t accidentally enabled “Lock Editor in Place”. That’s: Navigate > Editor > Lock in Place (from the menu). That sounds like the most plausible cause.

If the project really is somehow corrupted beyond repair (which I doubt), you can always dig into the .scriv file and pull out the RTF files one by one. But I’m sure it’s either a locked editor or something equally simple.

2 Likes

Yup, that was it. I have no idea how that setting got toggled, but following @dirkhaun’s steps I found the check mark, unchecked it, and can now navigate btw the different documents in the file.

Phew.

I appreciate being able to query this forum and get an answer so quickly.

Thanks,

–PS

2 Likes

That helped me too… I suspect I hit the wrong command while making a link :smiley:
Ellen

2 Likes

Thank you, this just helped me mitigate a heart attack! Yet slightly different. “Navigate → Binder Selection Affects: None” Fixed it by selecting “Current Editor”