CAPS for first word of each SCENE

I want to compile with the first word or two of each SCENE with CAPS. I’ve looked high and low and can’t seem to figure that out.

That one is a little out of the way. You need to go into your Formatting compile option pane and click on the row that describes the type of document used for scenes in the top half—most likely that will be a text file icon. Next, click on the Section Layout… button and then the “First Page” tab. You’ll find a control there for setting the number of words you wish to set to uppercase. You may need to do this to more than one of the rows, if multiple levels of text files are being used to generate scenes.

Thanks AmberV, I’ve tried that, but it only applies to the FIRST page of a chapter, not each scene.

Are the scenes in separate documents with their own outline level? If so, then this method – applied to that outline level – should work.

Katherine

Hi,

I’ve seen your Wish List item and think this might be a good option to add to a future version. In the meantime, however, you can achieve this using a bit of trickery with replacements - basically you need to have page breaks inserted but then remove them using replacements. (This assumes your scenes are all on separate documents - it won’t work otherwise.) Here’s how:

  1. In the Compile settings, under “Formatting”, select the level that affects scene documents and then click on “Section Layout…”.

  2. In the “Title Prefix and Suffix” pane, enter <$UPPERCASE_ME>" for the prefix (it doesn’t really matter what this tag is - just something that’s not likely to occur in the text).

  3. Under “Title Appearance”, tick “Insert title as run-in head”.

  4. Under “First page”, enter how many words you want to be made uppercase.

  5. Click “OK” to confirm the changes made to the section layout.

  6. Now switch to the “Separators” pane and set it up so that page breaks will be inserted before your scene documents - e.g. by changing “Text separator” and “Folder and text separator” to “Page break”.

  7. Switch to the “Replacements” pane > “Preset Replacements”.

  8. Now leave Scrivener briefly and fire up TextEdit.

  9. In TextEdit, create a new blank document.

  10. Still in TextEdit, in the new document, go to Edit > Insert > Page Break.

  11. Still in TextEdit, after the page break character that has just been inserted (which may just show up as an empty line if you’re not in page layout mode - that’s fine), type, “<$UPPERCASE_ME>” (without the speech marks) followed by a single space (the single space is important).

  12. Now hit Cmd-A followed by Cmd-C in TextEdit, to select all of the text you just created and copy it.

  13. Back in Scrivener, add a new preset replacement and paste the text you just copied from TextEdit into the “Replace” field.

  14. Double click into the “With” field, hold down the Option key and hit return (holding down Option allows you to enter paragraph breaks into text fields on OS X).

  15. Leave all of the tick-boxes for the replacement un-ticked.

  16. Compile.

What you’ve done here is “trick” Scrivener into adding all-caps for the first word of each scene by forcing a page break between each scene which then gets removed after the all-caps have been added. You use the arbitrary <$UPPERCASE_ME>" text so that the replacement doesn’t remove any page breaks you want to keep, only page breaks that appear at the start of a scene with uppercase characters.

As I say, I’ll probably add an option for this to a future version, but until then, this method should allow you to do it now. You can save your Compile settings for use with other projects, too, so you only need to set this up once.

Hope that helps.

All the best,
Keith