Change File Encoding

I brought a UTF-8 file over from Texshop (plain text) to Scrivener.
Certain characters, the usual suspects—em dashes, apostrophe’s—yielded nonsense characters in Scrivener.
Even though I thought Scrivener defaulted to UTF-8, apparently not.
Nor can I figure out a way to change the file’s encoding.
This answer
presupposes a Tools=>Options menu item in Scrivener. I don’t see it in the Mac version.
Export/Import options are in Preferences, but I can’t find an encoding option. Anywhere.
I will be exporting the file back to (hopefully) a UTF-8 text file.
How can I change the encoding of the Scrivener file to UTF-8?

Those are referring to instructions in the Windows version, which does have a text engine capable of specifying the encoding. The Mac version only uses UTF–8, so it is more likely the file you have isn’t what you thought it was. I have noticed TeXShop has some issues with encoding. For example if I save a plain text file using its default settings (presumably Windows Latin 9), I get a file that nothing will load correctly, not even TeXShop. The settings that work best for me are:

  • In the “Source” preference tab: set Encoding to “Unicode (UTF–8)”.
  • When saving a file, make sure “Unicode (UTF–8)” is set. I don’t think the format matters so much, that just changes the extension which is arbitrary for text.

This is the first instance of Windows Scrivener having greater functionality than Mac Scrivener.
Texshop is already set to UTF-8. But in a copy and paste through the OS, who knows what is happening?
Perhaps MacOS Roman is getting in the way…

Copy and paste—I was thinking purely through saving as files. Hmm, well it seems to be working fine for me. I would make sure you are up to date. I’m using TeXShop version 3.85.

To test the TeXShop output use the command-line with the following command:

pbpaste > ~/Desktop/test;file ~/Desktop/test

You should get “test: UTF–8 Unicode text” as a result, and if you open the “test” file with TextEdit it should look fine—and if you “Save As” from TextEdit, the offered encoding should be UTF–8.