Change Font for Whole Manuscript (Not for Compiling), Etc.

Okay, I figured out how to change the font for each new Scene I add, but I cannot find the place to change it for the whole thing, so that my default is Arial, and that each time I add a new Scene or Chapter, it will use Arial, not the annoyingly ugly serif’d Courier, which I hate with a passion that seems way too vehement for one to feel towards a little font. (Maybe I had a bad childhood experience with Courier or some other font with serifs? )

Note that I’m NOT talking about when I compile, I’m talking about what I’m looking at while I type.

(If there’s a way to change it so that I can make each new document appear as Arial, I’d love to know that as well! I’m not finding it in the manual. I’m sure it’s there, I’m just not finding it!)

I’m on the third scene of the first chapter of a new project, so pleasepleaseplease tell me I don’t have to start over from scratch to get this to work properly! (I dread this may be the case.)

Oh, as an aside, I’ve got two teeny questions that don’t really seem substantial enough for an entire post:

  1. Without being in the full-screen mode (I’ve figured it out in that mode, but I don’t work in that mode :frowning: ), how do I find or keep visible an ongoing word-count of the entire manuscript?
    1.a. I’m not sure how the word count on the title page gets its number, but mine doesn’t seem to be counting actual words in the manuscript. Am I supposed to replace the code in the cover page or something? (I did a quick-n-dirty compile for other reasons, to see how something would look, and I noticed this was way off.)

  2. And is there a way to do a “print preview?” For example, if I wanted to just print a scene or chapter or whatever section, I seem to be able to do that, but I can’t look at it ahead of time, as far as I can tell. Do you have to compile to do this? (That seems a bit much.)

I’m going to be guessing at menu items, since I’m sitting at my Mac, but hopefully this is close to reality:

Select File?-> Options, which brings up a new window.
Click on the tab for Formatting.
Using the preview of the text there, adjust those settings as you like.

This will affect all new documents that you create from now on.

To convert the existing documents, select them in the binder (CTRL-click or click on the first one, then SHIFT-click on the last one to select the ones in between), and select Documents->Convert->Convert to default formatting.

I hope the menu structure I used here was close – the actual functionality should be very close, but finding it can sometimes be a little bit of a hunt.

In the windows version, do this:
Tools > Options, then select the Editor-tab.
You will see a window inside the dialog-window
Click on the first icon top-left (A)
It will bring up formatting options.

Please note: This will not affect your tables, don’t know if this is a bug. Even worse, when you select a whole table (including empty cells) and reformat it, the formatted font refuses to apply to the empty cells. You are forced to type with the ugly font (and tiny on my hi-res monitor). Only then can you re-format existing text only.

Let me know if this is different on your machine.

Hehe, I can refer to this

Print Preview: I’ve been wondering about that, too. For my purposes, an uncompiled draft preview would be sufficient. But I cannot find an option for that, either, let alone for a complied preview.

Thanks, StefanG!

I knew it was just someplace I couldn’t find! I still can’t find it in the manual.

I don’t know about tables, though, sorry. I haven’t used any, and can’t actually think of a reason to at the moment (plus I’m still trying to figure out the basic stuff I need every day :slight_smile: ). Though if I have occasion to play around with that (who knows, I could get a writing job that requires it tomorrow!), I will indeed let you know.

But it either sounds like a bug, or perhaps the creator thought it should be treated separately. You mean you can’t change the font of a table AT ALL? I mean, I could understand if it were SEPARATE, but not at all DOES sound like a bug or an oversight. I hope someone with more knowledge will pop in and talk about that. <Hint, hint>

robertdguthrie,

Yeah, that's where I was looking, but it was a bit of a hunt.  It's a Windows thing: sub-sub-sub menus, or just which tab of manymanymany is it actually in. 

IOW, I was on the right street, but at the wrong door. :slight_smile:

Thanks to you both!
SUeMichele

Quick response as I need to run, but I just wanted to let you know the issue with formatting in tables and so forth is on the list–we’d definitely like to improve this. That said, tables should be using your current default font setting, not constantly reverting to Courier New–so if you’ve used the Editor tab in Options to set a new font to Georgia, say, then when you create a new document and create a table in that document, it should use Georgia. Likewise, if you then change your default font to Times New Roman and use the Documents > Convert > Formatting to Default Text Style command on that document, the text in the table should convert to TNR along with the rest of the page. If this isn’t what’s happening for you, can you give me steps to reproduce what you’re getting?

For previewing, this is an option–just choose “Preview” from the Compile For pop-up menu when you go to Compile. It’s not an exact print preview (for that, best option is to compile to PDF) but it will let you see what text is coming out, fonts, etc. This is just due mainly to the fact that that all the layout requires a compile to get it all worked out, so it’d really end up just the same as compiling a PDF as far as how long it takes–there’s not really an ability to do a live preview, which is why you have the sample text in the formatting pane to work on setting that as you want it.

Hi,
Me too. Every version of Scrivener for Windows I’ve had, no matter how many times I adjust the font preferences in Options/Appearance, every new scene I create(Ctrl & N) in every project defaults to Courier too - and I hate Courier with a fiery passion. Having to stop at every new scene to change the font back to something inoffensive is really irritating. I have uninstalled, gone back to defaults, changed them again - nothing gets rid of the cursed thing. Hoping for a change to this soon - everything else is great (but this is infuriating!) :smiley:

Default font for the editor needs to be changed in the Editor tab of Tools > Options… – nothing in the “Appearance” tab will affect this. That may’ve just been a typo, but as I still am unable to reproduce this problem of new documents not taking the designated text, I just want to double-check. So to go through this:

  1. Open Tools > Options… and click the “Editor” tab
  2. Click the blue “A” button on the far left of the format bar above the sample text area
  3. Set the font and click OK (the new font should be displayed in the text preview area)
  4. Click OK to close the Options window
  5. Create a new document anywhere in the binder
  6. Load that document in the editor if it isn’t automatically loaded (it will be unless you had the editor locked) and then type in the document

The document created in step 5 should be using the new font you selected in step 3. If you’re not getting that, can you share the steps you’re taking so I can try to reproduce this (and ultimately then get a fix, if there’s a bug somewhere in here)?

Thank you - I will try this later & let you know. Much appreciated.

I had been struggling with this too! Thanks for posting question and answers.

I still am unable to get the default font to stick to newly created tables. Is this on the list for the next version or is there xml that I could add to the XML file to affect tables?