Changing background color deletes connections

I had an open Scapple document with a few hundred notes, some connected by lines or arrows and some not. I changed the background color to black (just to see how it would look), and when I changed it back to the default background color, the connecting lines were gone.

Unfortunately, the background color change isn’t an action that shows up in the undo registry, so it appears the only way to get the connections back is to manually re-create them. Obviously I can avoid this mistake in the future now that I know, but hopefully it’s something that can be fixed in the next version.



Okay, I now see that the connections are still there…but they are now colored white. When I changed the background color to something dark, the connections and text turned white to be legible against the dark background. Next, when I changed it back to the default background color, the text reverted to black again, but the connections stayed white. I can’t read them because it’s currently white on white.

So right now, if I put the background color to a light grey or anything darker than white, I can still see the white connecting lines. But is there a way (other than manually deleting and re-creating) to change the connections back to black?

Thanks for any help!

Just to resurrect an old thread: the problem is still there. The color of the lines stays white when changing back to a lighter background color i. e. white. When you add connections in with the white background they appear black as usual.

– Jabrekk

Sorry, seems closing and reloading the file solves the issue. All connections are back to black.

I just had this happen to me for the exact same reason: fooling around with background settings for the heck of it. I freaked out when I went back to default and my lines were gone. Closing and reopening did work to fix it (thank goodness!), but it would be nice if this wasn’t an issue in the first place.

Has this been solved yet?

It doesn’t look like it and I suspect it won’t be until the new Scrivener is ready.

However, I think I have a workaround.

Select everything (Ctrl+a)
In the Inspector, go to document
Press clear next to the text color option
The connections should show again

Of course this will mean that any notes, where the text is not the default colour, will now be that colour.