Changing the font in all scenes at once?


I’m a new user of Scrivener (LOVE IT)…and I imported files that were in a font that I don’t want to use. Unfortunately, I didn’t just change the font in the original document before importing, which would have been the easiest thing to do. I’ve already separated most of it out into separate scenes, before I thought about this issue.

I know how to change each scene’s font - but is there a way to select all files (and folders preferably) and be able to change the font in all of them at once? I tried it but it doesn’t work - but I’m hoping I just don’t know the right way. It’ll be time consuming to have to change every scene at this point.

I did try to search the forums & help topics for this before posting - so if it is a simple fix and is in a FAQ/Help topic somewhere I apologize in advance!


It is indeed a simple fix, check here for instructions.

Hi, thanks for the link. However, I tried that and got this message:

“Converting document style cannot be undone. Please note that batch conversion is destructive and some documents may lose certain formatting and attributes.”

“Destructive” scared me. I guess I was thinking along the lines of “corrupting” files & losing data. I don’t really care about the formatting of my text that was imported, so as long as it’s not destructive to the actual text this would do the trick. Can you verify that it won’t cause loss or “destruction” of any text? I tried it on a small number of scenes and it worked great, but I am still a bit hesitant to do it in bulk until I learn more about what destructive really means.

Thanks again for your patience & help! :slight_smile:

It definitely won’t lose you any text - it only affects formatting. It’s “destructive” just because it cannot be undone; suppose you chose to convert everything to Lucida Grande font, which doesn’t support italics - you wouldn’t be able to get those italics back. Even if you re-converted you’d have to go through and add the italics manually. Likewise, any paragraphs formatted as block quotes would lose their block quote formatting, and you’d have to go back and manually add it again. But the text itself stays intact.
Hope that helps.
All the best,

Hi Keith,

Excellent! That makes me feel a lot better. And glad you told me about Lucida Grande & italics - I didn’t know that. :blush:

Thank you very much for your quick response!

I’ve updated the wording in the FAQ to explain this issue with not being able to undo, as it comes up frequently. Hmm. Might add another answer entirely to address it, now that I think about it.

Thanks Amber for posting the FAQ - looks great. It also looks like the Scrivener “Show Fonts” menu has the same information as Font Book under the Typeface column for which styles are supported for each font.

One last question about the Convert Formatting tool: I tried to use it by selecting first individual FOLDERS and then by selecting the entire MANUSCRIPT but it did not actually convert the font in either method, so is this command only possible by selecting individual files within each folder of the whole manuscript?

Correct on both counts. I considered the Show Fonts route, but that panel is a bit tricky in that if you size it the wrong way, Apple has designed it so that important parts of its interface just disappear, and this has caused confusion in the past. Sometimes the best thing to do is explain the route of absolute least confusion in a FAQ.

On your second point, the menu command only impacts selected items, to avoid accidentally causing global havoc. In practice this is super-easy to work around. Just click on the Draft item in the Binder, press Cmd-1 to enter Outliner mode, Cmd-A to select all, and then Option-RightArrow to reveal the entire draft in the outliner. Cmd-A again and then run the format converter. This way you needn’t foul up your Binder arrangement.

Thanks! That makes sense about the FAQ…

On your directions:

Option-RightArrow didn’t work for me. Option-Command-4 did, however (it was the only active option in the Edit Scrivenings menu > Selection). Are the commands something that are able to be changed, which might account for this difference? I didn’t find the Option-RightArrow listed in the Scrivener Finder Shortcuts.

Also - can you elaborate on how the Binder arrangement is affected by running the format converter directly? Thanks - still learning! :slight_smile:

My mistake, I left out one step as implied. After you click on the Draft item in the Binder and press Cmd-1 to show the Outliner, you have to move the keyboard focus over to the Outliner. Either just click anywhere in the editor area with the mouse, or press Cmd-Opt-Ctrl-E.

That said, creating an Edit Scrivenings session on the entire Draft will also accomplish a global font reset. It can just take a little longer to do that if the book is quite long as it has to assemble all of the text together. Outliner just loads the titles and such and is thus much faster. Not a big deal until your book is closer to completion and Edit Scrivenings has to load 100,000 words or whatever.

You may not have found Option-RightArrow in any shortcut lists, because it is a bit of a Mac convention. Option-clicking on a disclosure arrow, as well as Option-RightArrow when a folder or something is selected will often expand everything as far as it can go. Not all applications do this, but Scrivener is one.

The Binder arrangement is not affected by the format command, to clarify. Using the Outliner is just a way to expand your entire book temporarily and enable selecting the entire thing at once. For example, if you have 30 chapters and two of them are open in the Binder for editing, it could be annoying to Option-RightArrow the Draft, select everything, run the command, and then close everything back up to the way it was. Doing everything in the Draft Outliner is just an alternate way to access everything. That’s all I meant by “fouling things up”.

The reformat command does absolutely nothing to binder order. All it does is adjust the text for everything currently selected, be that in the Binder, the Outliner, Corkboard, Search Results, and so on (not to muck things up too much! Ha).

Wow, thanks for all that info Amber. Much appreciated!

It’ll take me a bit to get up to speed on some of the things you mentioned, but sounds like there is a lot of flexibility in the program. I’m lovin it so far. It’s exactly what I’ve needed, but I digress…

And I’m a new Mac owner, too - so that’s why I didn’t know the Option-RightArrow. :slight_smile:
So thanks!

Not a problem! And incidentally Option-LeftArrow does what you’d expect: collapses absolutely everything (from that point down, not siblings or parents, in outliner terminology). Ordinarily LeftArrow will just collapse the selected element and leave everything below in whatever collapse or un-collapse state it had been. So it’s useful to clean up an outline view.

I’m coming to this very late - but I need to do the same thing. The default font seems to be Optima 13 point; I’d like to make it Times New Roman 12 point (which is actually required by the Amazon contest, for example!). But I just can’t seem to manage it. I tried to follow the steps you gave and managed it up till the last one. That is, I got my novel in the outliner and got it highlighted. But choosing the new font doesn’t actually change any of my highlighted text. Also, how do you change the default font? Again, I thought choosing the font I wanted from the text menu would do it, but it doesn’t seem to. There doesn’t seem to be an “apply” button.

I know this is a very obvious question, but I’m baffled. TIA!


This is covered in the FAQ on the wiki ( and in the Help file, and has been answered many times on the forums, but here you go:

  1. Using the Text Editing pane of the Preferences, set the formatting you want using the text view at the top. This will be used for new documents.
  2. For any existing documents, select the ones you want to update in the binder and use Documents > Convert > Formatting > to Default Style to change them to use the formatting you set in the Preferences.

Hope that helps.
Have a great weekend,

Thanks! I would not have chimed in except that I found this thread, tried to follow the instructions in it, and failed. I now know what I was doing wrong, but I still couldn’t change all of my novel at once - chapter by chapter worked.

I think I probably have to go through the tutorial again. The program has lots of features I have never used. I’m just in love with the corkboard and how easy it makes it to write incrementally.