Changing the Scrivener 3 language

I just recently purchased scrivener and I noticed that it’s set in American English, not British English. How do I go about changing the dictionary and spellcheck language?

Theoretically you go File > Options > Language

In practice however, this only gives a general “English” option - which I have to assume is English (US) because it keeps telling me to spell analyse with a z.

There is also an option to make Scrivener use the computer’s system language - which I also have set to English (UK) - but this does not appear to help either as I get the same problem.

Hoping the team can fix these issues soon as being wrongly accused of poor spelling is annoying. (Telling Scrivener 3 to learn the new spelling made no difference either)

Quick update - I found this post a little further down the list - there is a separate dictionary used for corrections for some reason and it is possible to access correct versions here.

https://forum.literatureandlatte.com/t/problem-with-setting-the-spell-schecker-language/95058/3