Chapter epigraphs above chapter number and title

I’ve searched the manual and searched the forum, but I cannot figure out how to have epigraphs at the beginning of a chapter appear above the chapter number and chapter title on the first page of the chapter.

I believe I’ve got it established that to have the epigraphs formatted a certain way that’s different from the body text, I have to format them the way I want them and use “Preserve Formatting” on them. But so far I can’t see any way to have them appear where I want them.

Would someone be kind enough to point out what I’ve overlooked or misunderstood?

Having the epigraph appear before the chapter heading would be very unusual. The best solution I can think of is to use custom meta-data to store the quote and attribution, and then put it in the title prefix field, and the rest of the title in the suffix field (probably leaving the actual “Title” checkbox disabled in Formatting, and using the <$title> placeholder in the suffix field by hand).

The main problem with this is that custom meta-data is plain-text, so you’ll have to format it in the Formatting compile option pane, and you’ll only be able to apply one font, variant and size to the entire thing. Formatting applies to the whole prefix field. Likewise the “Chapter X” part and the actual title would need to use the same font settings.

[size=80]Example Formatting Compile settings[/size]

Of note:

  1. I put the punctuation in the Prefix field and split the epigraph and attribution into two different custom fields. This way I have to type less in the inspector. One could just as easily put the whole thing in one custom field with all punctuation typed in as well.
  2. The paragraph break after the Prefix is pretty crucial.
  3. Since <$title> is used in the Suffix field, the “Title” checkbox should obviously be disabled in the main Formatting pane. We don’t want the “Title” part to appear above the chapter number, as it ordinarily would be inserted prior to the suffix. Using the token lets you place the title anywhere you like.

Thanks for your help.

Because I’m trying in all good faith to find Scrivener workable for projects I have to do, I deferred to your judgment about placement of epigraphs—although I’ve designed books for many years, and a number of them have had epigraphs above chapter titles.

I don’t know how many hours I’ve now spent going through the manual, “Scrivener for Dummies,” the extensive tutorial, and the video tutorials, yet nothing I do will keep the chapter title, the epigraphs, and the initial chapter text on a single page of output when I do a compile.

I have the epigraphs set as text in a “folder” in the Binder that has the chapter name, with “Preserve Formatting” on the epigraphs. In Compile, that folder is set to output title and text.

Below that folder, as a child of it, is a text document that has children text documents. It contains the first actual text of the chapter—which does not have a separate subtitle. I had to do it this way because I want the first line as small caps, and if I put the opening chapter text in with the epigraphs, the first line of the epigraphs, not the chapter body text, gets made into small caps. This text document is selected in Compile to output the text only.

Below that text document, as children of it, are several other text documents, each a sub-section of the chapter, each with a subtitle. That level is set in Compile to output both title and text.

There are no page breaks set in the Compile “Separators” category except between folders and text documents. Yet every time I compile for print, the chapter title and epigraphs are on the first page of the compiled output, and the actual chapter text doesn’t start until the top of the next page.

I’ve tried everything I know. It’s among the most maddening experiences I’ve had with software.

UPDATE TO ADD: I compiled it as a Word document, and, sure enough, there’s a page break after the epigraphs. Nothing in Scrivener indicates that there is a page break, or should be one. :confused:

UPDATE 2: I’ve finally located the cause of the infuriating page break. It was hidden in “meta-data” for the document that starts the actual text of the chapter. I certainly never set the check box for “page break before.” Is this gratuitous “help” the program gives and doesn’t mention? It should put up a flashing neon notice: “I JUST FORCED A PAGE BREAK BEFORE THIS DOCUMENT YOU CREATED!” :unamused:

Here’s a crazy thought: wipe out all the automatic chapter numbering and epigraph code from the Prefix & Suffix compile settings.

In the Formatting pane of the compile window, tick the “text” column for your chapter folders.

Now, in each folder (not in a document “in” the folder, but the folder itself), add the epigraph, the chapter title, and the “CHAPTER <$n>”, formatted as you like, then tick the “compile as is” checkbox for the folder.

To add text to a folder (which is just a document with a special “folder” property), you may have to enter scrivenings mode with the folder selected; it will be the first blank area before the text of any of the documents below it. You’ll be able to tell you are adding to the folder’s text area by looking at the inspector; if the synopsis index card has the title of the folder as it’s title, you’re in the right place.

It’s not that I disagree that the epigraph must follow the chapter title, I’ve just never seen it done so I wanted to make sure that is what you really wanted. We see all types come through here. :slight_smile: Many people have never designed a book before. You should do whatever you prefer, I am just explaining why Scrivener treats the section heading as the absolute beginning terminator.

Another approach that might work: have the epigraph in its own file. Set it to As-Is (or use Preserve Formatting) and Page Break Before. Then make it so all folders do not insert a page break in the Separators pane. That way the epigraph file will be the one making the cut, and the folder following it will create the title. The drawbacks to this method are that it produces a rather odd outline structure, and you’ll have to manage page breaks by hand.

Page Break Before: nothing sets that on by default in the software, it must have been toggled at some point. Whatever the case, when you have situations where page breaks are acting exotic, these checks can help locate it:

  1. First check the Separators compile option pane and make sure all of that is in accordance with the book outline.
  2. Next check the Contents pane. Page Break Before is provided as a column in this list, along with Compile As-Is. This makes it a valuable place to make sure no stray items got their checkboxes enabled.
  3. Finally turn on invisibles in Format/Options and poke around the area that has the extra break. Page breaks will show up as a blue vertical bar on a line by itself.

Thanks, robertdguthrie, for your suggestions, and thank you, AmberV, for your explanations and suggestions.

I have no idea what could have toggled on the “page break before” box in the meta-data. I tried so many different things trying to get things set up the way I wanted them that I somehow may have—but I certainly did not do it intentionally or manually, and it remains of some concern to me that the program is capable of such hidden flags. By “hidden” of course I don’t mean intentionally hidden, but I had never intended to use meta-data at all, so I’d never had it opened in the sidebar, and it took quite a bit of digging to figure it out.

I started out with one of the supplied non-fiction themes, because that’s the type of project I’m trying to use Scrivener for. Whether that’s a “feature” of that theme or not, I simply don’t know and don’t have the time at the moment to try to find out.

Thank you again for your generous help.

The non-fiction templates do have some example structure in them, and that includes a Contents section as well as a Forward. These are set to have a page break since that would be typical, and they are otherwise not in a condition to produce automatic page breaks. So I don’t know, maybe if you duplicated off of one of those instead of making a new text document. Duplication retains all of the characteristics of an item, including its meta-data.

I’m not sure what you are advocating otherwise. The practice of putting lesser used functions in panels to toggle the visibility of them is a good and modern approach. Granted it can sometimes work against your favour if the thing you are looking for is in an area you’re unfamiliar with—but there is no universal solution to that problem (short of going back to the '90s and making software a mass of confusing toolbars again). For you it was this one checkbox, for someone else it is some other thing. Probably every feature in Scrivener has tripped up someone somewhere for a while.

No, I didn’t duplicate a Contents or Forward page for the pages inside chapters.

With all due deference, probably every feature in every software program has tripped up someone somewhere for a while, but I’m not aware of any word processor software, or document layout software, that doesn’t supply a means of seeing such fundamental structure-altering codes within the editor itself, where the text appears—no matter what method was used to insert such non-printing characters. Scrivener’s “Show Invisibles” doesn’t show forced page breaks.

Of course I don’t lay claim to being a master of all such software, but I believe I reasonably could claim some familiarity with most, and in my experience, Scrivener seems to be unique in this omission.

Yeah, I’m not aware of any like that, either. If you’ve only worked with programs that have a WYSIWYG approach to writing, then yes that may seem strange to put a page break in a checkbox instead of as a symbol, or simulation of paper being “used” on the screen. However this is not at all unique amongst software designed to work as a long document construction kit in a “semantic” form where you have a collection of data that is assembled into a single document using style settings and myriad other structural and appearance tools (compiling). Indeed, many of the fundamental and structural things about a book make no appearance at all in Scrivener’s main text editor. Amongst programs of this type, that is normal and the desired result.

As a matter of fact, I only will work with programs that at least allow a WYSIWYG approach, because I’m in a high-level production environment that demands it. I don’t have the luxury of playing peek-a-boo with crucial formatting functions.

I don’t hand-code vector graphics in PostScript, either.

Then it shouldn’t be any problem for you to list some of the “many.” What are they? So far, forced page breaks is the only one I’ve encountered, and I consider it a major omission. YMMV.

Desired by whom?